<!DOCTYPE html>
<html lang="en">
<head>
<meta property="fb:app_id" content="1495581714056366"/>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<title>RDOS mosquito prevention program expanding to cover Princeton, Keremeos and Naramata - Penticton News - Castanet.net</title>
<meta name="twitter:card" content="summary_large_image"/>
<meta name="twitter:site" content="@CastanetNews"/>
<meta property="og:type" content="article"/>
<meta property="article:publisher" content="https://www.facebook.com/Castanet.net"/>
<meta property="article:content_tier" content="free"/>
<meta property="article:opinion" content="false"/>
<meta property="og:title" content="RDOS mosquito prevention program expanding to cover Princeton, Keremeos and Naramata - Penticton News"/>
<meta property="article:tag" content="Science & Tech"/>
<meta name="description" content="Mosquito control is heading towards a full regional service for 2023 throughout the entire Regional District of Okanagan-Similkameen, adding in Princeton, Keremeos and Naramata. "/>
<meta property="og:description" content="Mosquito control is heading towards a full regional service for 2023 throughout the entire Regional District of Okanagan-Similkameen, adding in Princeton, Keremeos and Naramata. "/>
<script src="/cdn-cgi/apps/head/xWaxO5HBfKVD5Vfk-QoB64H5pT8.js"></script><link rel="canonical" href="https://www.castanet.net/news/Penticton/363198/RDOS-mosquito-prevention-program-expanding-to-cover-Princeton-Keremeos-and-Naramata"/>
<meta property="og:url" content="https://www.castanet.net/news/Penticton/363198/RDOS-mosquito-prevention-program-expanding-to-cover-Princeton-Keremeos-and-Naramata"/>
<meta property="og:image" content="https://www.castanet.net/content/2022/3/screen_shot_2020-04-15_at_4.13.57_pm_p3452579_p3582713.jpg"/>
<link href="https://www.castanet.net/rss/page-21.xml" rel="alternate" type="application/rss+xml" title="Castanet - Penticton" />
<meta name="referrer" content="always"/>
<link rel="dns-prefetch" href="https://www.google-analytics.com/" />
<link rel="preconnect" href="https://www.google-analytics.com/" />
<link rel="preconnect" href="https://fonts.googleapis.com"/>
<link rel="preconnect" href="https://fonts.gstatic.com" crossorigin/>
<link href='https://fonts.googleapis.com/css?family=Open+Sans:400,600&display=swap' rel='stylesheet' type='text/css'/>
<!--[if lt IE 8]><link rel="stylesheet" type="text/css" href="/css/ie7.css" /><![endif]-->
<link rel="stylesheet" type="text/css" href="/css/new89.css" />
<link rel="stylesheet" type="text/css" href="/css/business8.css" />
<style type="text/css">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</style>
<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.8/jquery.min.js"></script>
<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jqueryui/1.8/jquery-ui.min.js"></script>
<script type="text/javascript" src="/js/tools-2news.js"></script>
<script type="text/javascript">
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
ga('create', 'UA-802263-1', 'auto');
ga('send', 'pageview');
</script>
<script type="text/javascript">
var _comscore = _comscore || [];
_comscore.push({ c1: "2", c2: "6034663" });
(function() {
var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
s.src = "https://sb.scorecardresearch.com/cs/6034663/beacon.js";
el.parentNode.insertBefore(s, el);
})();
</script>
</head>

<body>
<noscript><img src="https://sb.scorecardresearch.com/p?c1=2&amp;c2=6034663&amp;cv=3.6.0&amp;cj=1" alt="" /></noscript>
<div class="mobileframe">
<div id="frame">
<script type="text/javascript">var sfPage="sfNews";</script>
<div id="mh" class="kelowna-mh">
	<div id="hd">
		<div id="hdl">
			<a href="/"><img srcset="/img/mh/castanet-logo.svg" src="/img/mh/castanet-logo.png" alt="Castanet" title="Go Home" class="mhlogo" width="225" height="37"/></a>
		</div>
		<div id="hdr">
<div id="hdrwx">
<a id="header_weather" href="https://www.castanet.net/weather/Kelowna" title="Kelowna Weather" style="position:relative;margin:0;background:url('//www.castanet.net/images/weather/icon/12.png') no-repeat top;background-size:50px 40px;width:50px;height:40px;text-decoration:none;color:#000"><span style="position:absolute;top:14px;left:10px">7&deg;C</span></a></div>
<div style="float:right;margin-right:5px"><a href="https://castanetapparel.com/?utm_source=castanet.net&amp;utm_medium=masthead" target="_blank" rel="noopener"><img src="/img/mh/Castanet-Apparel.png" width="98" height="40" alt="Castanet Apparel"/></a></div>
		</div>

<div style="clear:both;margin:0 0 0 5px;line-height:18px">
<div id="hdedition" title="Choose your city">
<span>city</span>
<a id="cityl" href="https://www.castanetkamloops.net/">&lsaquo;</a>
<a id="cityr" href="https://www.castanet.net/vernon/">&rsaquo;</a>
</div>
<div id="myhomepage">
<a href="https://www.castanet.net/vernon/" title="Choose your city">Kelowna's Homepage</a> <span><a class="hpselect" title="Kelowna" href="https://www.castanet.net/kelowna/">&#9679;</a><a title="Vernon" href="https://www.castanet.net/vernon/">&#9679;</a><a title="Penticton" href="https://www.castanet.net/penticton/">&#9679;</a><a title="Kamloops" href="https://www.castanetkamloops.net/">&#9679;</a></span>
</div>
<div class="searchmh">
<a href="https://www.castanet.net/events/" title="What's happening today?" id="mhdate">Thursday, Mar 17</a><form class="mhsform" name="newsearchg" action="https://www.google.com/search">
<input type="text" name="q" title="Google" placeholder="Google" autocomplete="off"/>
<input type="image" name="submit" src="/images/mhsearchbutton.png" style="width:15px;height:15px;position:absolute;top:0px;right:2px" alt="Submit"/>
</form>
</div>
<div class="searchmh" style="margin:0">
<form class="mhsform" name="newsearchc" action="/search-news/">
<input type="text" name="q" title="Castanet" placeholder="Castanet" autocomplete="off"/>
<input type="image" name="submit" src="/images/mhsearchbutton.png" style="width:15px;height:15px;position:absolute;top:0px;right:2px" alt="Submit"/>
</form>
</div>

<div id="hdrbuttons">
<a id="hdflyers" title="Obituaries" href="/obituaries/">Obits</a><a id="hdautomall" title="AutoMall" href="https://www.castanetautomall.com/" target="_blank" rel="noopener">AutoMall</a><a id="hdevents" title="Events" href="/events/">Events</a><a id="hdcams" title="Cams" href="/scenic-web-cams/">Cams</a><a id="hdtango" title="The Tango" href="https://thetango.net/" target="_blank" rel="noopener">Tango</a>
</div>
</div>

	</div>
<div class="megawrap">
<ul class="sf-menu" id="megamenu">
	<li id="sfNews">
	<a href="/">Home</a>
	<div class="sf-mega">
<div class="sf-mega-frame">
	<div class="sf-mega-section">
	<ul class="sf2col">
<li><a href="/edition/news-story--1-.htm">Kelowna</a></li>
<li><a href="/edition/news-story--101-.htm">West Kelowna</a></li>
<li><a href="/edition/news-story--21-.htm">Penticton</a></li>
<li><a href="/edition/news-story--2-.htm">Vernon</a></li>
<li><a href="/edition/news-story--61-.htm">Salmon Arm</a></li>
<li><a href="/edition/news-story--48-.htm">Kamloops</a></li>
<li><a href="/edition/news-story--2022-.htm">Beijing 2022</a></li>
</ul>
<ul class="sf2col2">
<li><a href="/edition/news-story--11-.htm">Poll</a></li>
<li><a href="/edition/news-story--10-.htm">Letters</a></li>
<li><a href="/edition/news-story--42-.htm">Get Involved</a></li>
<li><a href="/opinion/">Opinion</a></li>
<li><a href="/edition/news-story--1000-.htm">What's up</a></li>
<li><a href="/edition/news-story--71-.htm">Coronavirus</a></li>
<li><a href="/covid19-resources/">COVID-19 Community Resources</a></li>
</ul>
<div style="clear:both"></div>
	</div>
</div>
	</div>
	</li>
	<li id="sfBC">
	<a href="/edition/news-story--3-.htm">BC</a>
	<div class="sf-mega">
<div class="sf-mega-frame">
	<div class="sf-mega-section">
	<ul>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:10px 0 15px 0"><a href="/edition/news-story-363199-3-.htm#363199"><img src="/content/2022/3/square/thumb/20220317140344-6233818a47885e3d8117fe1fjpeg_p3582715.jpg" alt="Story 363199" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Helping youth out of care<br/><span style="font-size:11px">BC 12:21 pm - 701 views</span></a></li>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:0 0 15px 0"><a href="/edition/news-story-363193-3-.htm#363193"><img src="/content/2022/3/thumb/363193_0.jpg" alt="Story 363193" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Government in full ad blitz<br/><span style="font-size:11px">BC 11:35 am - 5,734 views</span></a></li>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:0 0 15px 0"><a href="/edition/news-story-363179-3-.htm#363179"><img src="/content/2022/3/thumb/363179_0.jpg" alt="Story 363179" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>3D printing testicular cells<br/><span style="font-size:11px">BC 10:34 am - 3,427 views</span></a></li>
</ul>
<ul class="sf2col">
<li><a href="/edition/news-story--1-.htm">Kelowna</a></li>
<li><a href="/edition/news-story--101-.htm">West Kelowna</a></li>
<li><a href="/edition/news-story--21-.htm">Penticton</a></li>
<li><a href="/edition/news-story--2-.htm">Vernon</a></li>
<li><a href="/edition/news-story--61-.htm">Salmon Arm</a></li>
<li><a href="/edition/news-story--48-.htm">Kamloops</a></li>
</ul>
<ul class="sf2col2">
<li><a href="/news/Peachland/">Peachland</a></li>
<li><a href="/news/Vancouver/">Vancouver</a></li>
<li><a href="/news/Victoria/">Victoria</a></li>
<li><a href="/news/Prince%20George/">Prince George</a></li>
<li><a href="/news/Nelson/">Nelson</a></li>
</ul>
<ul style="clear:both">
<li class="sf-menu-icon"><a href="/edition/news-story--3-.htm" class="bc-icon">All BC News</a></li>
	</ul>
	</div>
</div>
	</div>
	</li>
	<li id="sfCanada">
	<a href="/edition/news-story--4-.htm">Canada</a>
	<div class="sf-mega">
<div class="sf-mega-frame">
	<div class="sf-mega-section">
	<ul>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:10px 0 15px 0"><a href="/edition/news-story-363202-4-.htm#363202"><img src="/content/2022/3/square/thumb/20220317110324-623352df3d4873357f0daa85jpeg_p3582709.jpg" alt="Story 363202" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Reaching out to refugees<br/><span style="font-size:11px">Newfoundland 12:35 pm - 550 views</span></a></li>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:0 0 15px 0"><a href="/edition/news-story-363178-4-.htm#363178"><img src="/content/2022/3/square/thumb/20220317130316-62336d4fd1a25c78bd6cd1bcjpeg_p3582684.jpg" alt="Story 363178" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Ukrainians given 2 years<br/><span style="font-size:11px">Canada/Ukraine 10:32 am - 8,667 views</span></a></li>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:0 0 15px 0"><a href="/edition/news-story-363164-4-.htm#363164"><img src="/content/2022/3/square/thumb/b9ea554c61faf5112a8105894082a2e75c21a3afae9819416cd24af8994cc6bf.jpg_newsroom_base._p3582668.jpg" alt="Story 363164" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Steals RCMP weapon<br/><span style="font-size:11px">Alberta 9:31 am - 3,761 views</span></a></li>
<li class="sf-menu-icon"><a href="/edition/news-story--4-.htm" class="canada-icon">More Canada News</a></li>
	</ul>
	</div>
</div>
	</div>
	</li>
	<li id="sfWorld">
	<a href="/edition/news-story--5-.htm">World</a>
	<div class="sf-mega">
<div class="sf-mega-frame">
	<div class="sf-mega-section">
	<ul>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:10px 0 15px 0"><a href="/edition/news-story-363167-5-.htm#363167"><img src="/content/2022/3/square/thumb/9ef338eb8b721001f7d4b4208e4dbe554b6d5e31225562617e2889ef317aed2b.jpg_newsroom_base._p3582671.jpg" alt="Story 363167" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Cdns survive horrific crash<br/><span style="font-size:11px">Texas 9:36 am - 1,613 views</span></a></li>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:0 0 15px 0"><a href="/edition/news-story-363141-5-.htm#363141"><img src="/content/2022/3/square/thumb/1000._p3582632.jpg" alt="Story 363141" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Survivors in theatre rubble<br/><span style="font-size:11px">Ukraine 9:15 am - 6,576 views</span></a></li>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:0 0 15px 0"><a href="/edition/news-story-363144-5-.htm#363144"><img src="/content/2022/3/square/thumb/1000._p3582635.jpg" alt="Story 363144" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Cheap drones' deadly effect<br/><span style="font-size:11px">Ukraine 7:27 am - 9,623 views</span></a></li>
<li class="sf-menu-icon"><a href="/edition/news-story--5-.htm" class="world-icon">More World News</a></li>
	</ul>
	</div>
</div>
	</div>
	</li>
	<li id="sfBusiness">
	<a href="/edition/news-story--6-.htm">Business</a>
	<div class="sf-mega">
<div class="sf-mega-frame">
		<div class="sf-mega-section">
		<ul>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:10px 0 15px 0"><a href="/edition/news-story-363184-6-.htm#363184"><img src="/content/2022/3/square/thumb/20220317120324-623360b51e59da60ef902624jpeg_p3582682.jpg" alt="Story 363184" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Industry wants feds to step in<br/><span style="font-size:11px">Business 10:55 am - 2,937 views</span></a></li>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:0 0 15px 0"><a href="/edition/news-story-363162-6-.htm#363162"><img src="/content/2022/3/square/thumb/2022030713034-228a7af33621cdfe201aec57d35eaf83520495265f403809b39aedd1d01faf69_p3582663.jpg" alt="Story 363162" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>'Workcations' gain traction<br/><span style="font-size:11px">Business 9:18 am - 4,237 views</span></a></li>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:0 0 5px 0"><a href="/edition/news-story-363160-6-.htm#363160"><img src="/content/2022/3/square/thumb/2022031711034-62334df5e3c1c66c320e233ajpeg_p3582658.jpg" alt="Story 363160" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Oil pushes TSX higher<br/><span style="font-size:11px">Business 9:11 am - 672 views</span></a></li>
</ul>
<ul class="sf2col">
			<li><a href="/edition/news-story--66-.htm">Sponsored Video</a></li>
			<li><a href="/themarket/">The Market</a></li>
			<li><a href="/pressroom/">Press Room</a></li>
			<li><a href="https://classifieds.castanet.net/cat/services/">Services</a></li>
			<li><a href="https://classifieds.castanet.net/cat/real_estate/business_opportunities/">Biz Opportunities</a></li>
			<li><a href="/edition/news-story--63-.htm">Think Local</a></li>
</ul>
<ul class="sf2col2">
			<li><a href="https://okanaganedge.net/" target="_blank" rel="noopener" style="text-decoration:underline">Okanagan Edge</a></li>
			<li><a href="https://okanaganedge.net/category/okanagan-biz/" target="_blank" rel="noopener">Okanagan Biz</a></li>
			<li><a href="https://okanaganedge.net/category/bc-biz/" target="_blank" rel="noopener">BC Biz</a></li>
			<li><a href="https://okanaganedge.net/category/community/got-the-edge/" target="_blank" rel="noopener">Got the Edge</a></li>
			<li><a href="https://okanaganedge.net/category/community/get-involved/" target="_blank" rel="noopener">Get Involved</a></li>
			<li><a href="https://okanaganedge.net/category/business-buzz/" target="_blank" rel="noopener">Business Buzz</a></li>
		</ul>
<div style="clear:both"></div>
		</div>
</div>
	</div>
	</li>
	<li id="sfSports">
	<a href="/edition/news-story--7-.htm">Sports</a>
	<div class="sf-mega">
<div class="sf-mega-frame">
		<div class="sf-mega-section">
		<ul>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:10px 0 15px 0"><a href="/edition/news-story-363156-35-.htm#363156"><img src="/content/2022/3/square/thumb/warriors_p3582662.jpg" alt="Story 363156" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Warriors seek Irish magic<br/><span style="font-size:11px">BCHL 8:15 am - 987 views</span></a></li>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:0 0 15px 0"><a href="/edition/news-story-363098-7-.htm#363098"><img src="/content/2022/3/thumb/363098_1.jpg" alt="Story 363098" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Local skaters make Team BC<br/><span style="font-size:11px">Kamloops  - 1,909 views</span></a></li>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:0 0 5px 0"><a href="/edition/news-story-362767-7-.htm#362767"><img src="/content/2022/3/thumb/362767_0.jpg" alt="Story 362767" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Tom Brady ends retirement<br/><span style="font-size:11px">Sports  - 30,836 views</span></a></li>
</ul>
<ul class="sf2col">
			<li><a href="/edition/news-story--51-.htm">WHL</a></li>
			<li><a href="/edition/news-story--35-.htm">BCHL</a></li>
			<li><a href="/edition/news-story--44-.htm">BCFC</a></li>
			<li><a href="/edition/news-story--62-.htm">UBCO Heat</a></li>
			<li><a href="/golf/">Golf</a></li>
			<li><a href="/sports/penticton-speedway/">Penticton Speedway</a></li>
</ul>
<ul class="sf2col2">
			<li><a href="/sports/ski/">Ski</a></li>
			<li><a href="/ski/big-white/">Big White</a></li>
			<li><a href="/ski/silver-star/">Silver Star</a></li>
			<li><a href="/ski/apex/">Apex</a></li>
			<li><a href="/ski/baldy/">Baldy</a></li>
			<li><a href="/ski/sun-peaks/">Sun Peaks</a></li>
		</ul>
<div style="clear:both"></div>
		</div>
</div>
	</div>
	</li>
	<li id="sfShowBiz">
		<a href="/edition/news-story--8-.htm">ShowBiz</a>
		<div class="sf-mega">
<div class="sf-mega-frame">
		<div class="sf-mega-section">
		<ul>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:10px 0 15px 0"><a href="/edition/news-story-363153-8-.htm#363153"><img src="/content/2022/3/square/thumb/bang_66649_p.jpg" alt="Story 363153" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>'Avatar 2 made me cry'<br/><span style="font-size:11px">Entertainment 8:02 am - 1,824 views</span></a></li>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:0 0 15px 0"><a href="/edition/news-story-363152-8-.htm#363152"><img src="/content/2022/3/square/thumb/bang_66625_p.jpg" alt="Story 363152" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Pete gets tat for Kim<br/><span style="font-size:11px">Entertainment 7:59 am - 1,301 views</span></a></li>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:0 0 5px 0"><a href="/edition/news-story-363150-8-.htm#363150"><img src="/content/2022/3/square/thumb/bang_66638_p.jpg" alt="Story 363150" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Bynes' remarkable recovery<br/><span style="font-size:11px">Entertainment 7:56 am - 1,165 views</span></a></li>
</ul>
<ul class="sf2col">
		<li><a href="https://tvlistings.zap2it.com/">TV Listings</a></li>
		<li><a href="/books.htm">Books</a></li>
		<li><a href="/edition/news-story--25-.htm">Offbeat</a></li>
		<li><a href="/edition/news-story--57-.htm">Around the Web</a></li>
		<li><a href="/edition/news-story--949-.htm">Heather's Horoscope</a></li>
</ul>
<ul class="sf2col2">
		<li><a href="https://thetango.net/" target="_blank" rel="noopener" style="text-decoration:underline">The Tango</a></li>
		<li><a href="https://thetango.net/category/daily-dose/" target="_blank" rel="noopener">Daily Dose</a></li>
		<li><a href="https://thetango.net/category/must-watch/" target="_blank" rel="noopener">Must Watch</a></li>
		<li><a href="https://thetango.net/category/galleries/" target="_blank" rel="noopener">Galleries</a></li>
		<li><a href="https://thetango.net/category/showbiz/" target="_blank" rel="noopener">Showbiz</a></li>
		<li><a href="https://thetango.net/category/music/" target="_blank" rel="noopener">Music</a></li>
		</ul>
<div style="clear:both"></div>
		</div>
</div>
		</div>
	</li>	
	<li id="sfClassifieds">
		<a href="https://classifieds.castanet.net/">Classifieds</a>
		<div class="sf-mega">
<div class="sf-mega-frame">
		<div class="sf-mega-section">
		<ul class="sf2col">
<li><a href="https://classifieds.castanet.net/my_ads.php" class="sfbutton">Login</a></li>
			<li><a href="https://classifieds.castanet.net/live/">Marketplace Live</a></li>
			<li><a href="https://classifieds.castanet.net/cat/jobs/">Jobs</a></li>
			<li><a href="https://classifieds.castanet.net/cat/real_estate/">Real Estate</a></li>
			<li><a href="https://classifieds.castanet.net/cat/rentals/">Rentals</a></li>
			<li><a href="https://classifieds.castanet.net/cat/vehicles/">Vehicles</a></li>
			<li><a href="https://classifieds.castanet.net/cat/auto_parts/">Auto Parts</a></li>
			<li><a href="https://classifieds.castanet.net/cat/rec_vehicles/">Rec Vehicles</a></li>
			<li><a href="https://classifieds.castanet.net/cat/house-home/">House-Home</a></li>
			<li><a href="https://classifieds.castanet.net/cat/furniture/">Furniture</a></li>
			<li><a href="https://classifieds.castanet.net/cat/electronics/">Electronics</a></li>
			<li><a href="https://classifieds.castanet.net/cat/fashion/">Fashion</a></li>
			<li><a href="https://classifieds.castanet.net/cat/kids/">Kids</a></li>
			<li><a href="https://classifieds.castanet.net/cat/sports-health/">Sports-Health</a></li>
		</ul>
<ul class="sf2col2">
<li><a href="/help/" class="sfbutton">Help</a></li>
<li><a href="https://www.castanetautomall.com/" target="_blank" rel="noopener">Automall</a></li>
<li><a href="https://www.rvpowersports.com/" target="_blank" rel="noopener">RV-Boats-Powersports</a></li>
<li><a href="https://classifieds.castanet.net/flyers/">Flyers</a></li>
			<li><a href="https://classifieds.castanet.net/cat/hobbies-music/">Hobbies-Music</a></li>
			<li><a href="https://classifieds.castanet.net/cat/library/">Library</a></li>
			<li><a href="https://classifieds.castanet.net/cat/vintage-antiques/">Vintage-Antiques</a></li>
			<li><a href="https://classifieds.castanet.net/cat/home_improvement/">Home Improvement</a></li>
			<li><a href="https://classifieds.castanet.net/cat/commercial-business/">Commercial-Business</a></li>
			<li><a href="https://classifieds.castanet.net/cat/farmers_market/">Farmer's Market</a></li>
			<li><a href="https://classifieds.castanet.net/cat/horse-farm-pets/">Horse-Farm-Pets</a></li>
			<li><a href="https://classifieds.castanet.net/cat/services/">Services</a></li>
			<li><a href="https://classifieds.castanet.net/cat/garage-free-auctions/">Garage-Free-Auctions</a></li>
			<li><a href="/stores/">Stores</a></li>
			<li><a href="https://classifieds.castanet.net/Classifieds%20Rate%20Sheet%20-%20Sept%201,%202019.pdf" target="_blank" rel="noopener">Classifieds Rate Sheet</a></li>
</ul>
<div style="clear:both"></div>
		</div>
</div>
		</div>
	</li>
	<li id="sfRealEstate">
		<a href="/realestate/">Real Estate</a>
		<div class="sf-mega">
<div class="sf-mega-frame">
		<div class="sf-mega-section">
		<ul>
			<li><a href="https://classifieds.castanet.net/cat/real_estate/">Listings</a></li>
			<li><a href="https://classifieds.castanet.net/cat/rentals/">Rentals</a></li>
			<li><a href="/showhomes/">Showhome Showcase</a></li>
			<li><a href="/edition/news-story--31-.htm">Luxury Homes</a></li>
			<li><a href="/edition/news-story--1044-.htm">Investment Real Estate</a></li>			
			<li><a href="https://classifieds.castanet.net/cat/real_estate/open_houses_no_showhomes_please/">Open Houses</a></li>
		</ul>
		</div>
</div>
		</div>	
	</li>

	<li id="sfCommunity">
		<a href="/opinion/">Opinion</a>
		<div class="sf-mega">
<div class="sf-mega-frame">
		<div class="sf-mega-section">
		<ul>
			<li><a href="/edition/news-story--11-.htm">Poll</a></li>
			<li><a href="/edition/news-story--10-.htm">Letters</a></li>
			<li><a href="https://forums.castanet.net/">Forums</a></li>
			<li><a href="/columnists/">Columnists</a></li>
			<li><a href="/edition/news-story--56-.htm">Opinion</a></li>
		</ul>
		</div>
</div>
		</div>
	</li>
	<li id="sfCity">
		<a href="/our-town/">Our Town</a>
		<div class="sf-mega">
<div class="sf-mega-frame">
		<div class="sf-mega-section">
		<ul class="sf2col">
			<li><a href="/obituaries/">Obituaries</a></li>
			<li><a href="/themarket/">The Market</a></li>
			<li><a href="/adopt-a-pet/">Adopt-a-Pet</a></li>
			<li><a href="/events/">Events</a></li>
			<li><a href="/movies/">Movies</a></li>
			<li><a href="/scenic-web-cams/">Cams</a></li>
<li><a href="/gas-prices/">Gas Prices</a></li>
			<li><a href="/gallery/">Gallery</a></li>
<li><a href="/celebrations/">Celebrations</a></li>
<li><a href="/contests/">Contests</a></li>
			<li><span style="position:absolute;top:-2px;font-size:24px;text-decoration:none !important;color:#000">&lsaquo;</span> &nbsp; &nbsp;<a href="/city/" style="position:relative" onmouseover="flyout(this);" id="citylink" class="taphover">Cities </a>
<div>
		<ul class="sf2col">
			<li><a href="https://www.cityofarmstrong.bc.ca" target="_blank" rel="noopener">Armstrong</a></li>
			<li><a href="https://www.cityofenderby.com" target="_blank" rel="noopener">Enderby</a></li>
			<li><a href="https://www.kamloops.ca" target="_blank" rel="noopener">Kamloops</a></li>
			<li><a href="https://www.kelowna.ca" target="_blank" rel="noopener">Kelowna</a></li>
			<li>&nbsp;&nbsp;<a href="https://www.kelowna.ca/roads-transportation/parking/parking-tickets-service-requests" target="_blank" rel="noopener">Pay Parking Tickets</a></li>
			<li><a href="https://www.keremeos.ca" target="_blank" rel="noopener">Keremeos</a></li>
			<li><a href="https://www.lakecountry.bc.ca" target="_blank" rel="noopener">Lake Country</a></li>
			<li><a href="https://www.merritt.ca" target="_blank" rel="noopener">Merritt</a></li>
			<li><a href="https://www.oliver.ca" target="_blank" rel="noopener">Oliver</a></li>
			<li><a href="https://www.osoyoos.ca" target="_blank" rel="noopener">Osoyoos</a></li>
			<li><a href="https://www.peachland.ca" target="_blank" rel="noopener">Peachland</a></li>
</ul>
<ul class="sf2col2">
			<li><a href="https://www.penticton.ca" target="_blank" rel="noopener">Penticton</a></li>
			<li><a href="https://www.summerland.ca" target="_blank" rel="noopener">Summerland</a></li>
			<li><a href="https://www.vernon.ca" target="_blank" rel="noopener">Vernon</a></li>
			<li><a href="https://www.westkelownacity.ca" target="_blank" rel="noopener">West Kelowna</a></li>
			<li><a href="https://www.wfn.ca" target="_blank" rel="noopener">Westbank First Nation</a></li>
			<li><a href="https://www.regionaldistrict.com" target="_blank" rel="noopener">RDCO</a></li>
			<li><a href="https://www.rdos.bc.ca" target="_blank" rel="noopener">RDOS</a></li>
			<li><a href="https://www.tnrd.ca" target="_blank" rel="noopener">TNRD</a></li>
			<li><a href="https://www.interiorhealth.ca" target="_blank" rel="noopener">Interior Health</a></li>
			<li><a href="https://www.orl.bc.ca" target="_blank" rel="noopener">Library</a></li>
			<li><a href="https://ok.ubc.ca" target="_blank" rel="noopener">UBC Okanagan</a></li>
			<li><a href="https://www.okanagan.bc.ca" target="_blank" rel="noopener">Okanagan College</a></li>
		</ul>
</div>
			<img src="/mh/flyout-fin.png" alt="city links" class="flyout-fin" /></li>
		</ul>
<ul class="sf2col2">
			<li><a href="/edition/news-story--42-.htm">Get Involved</a></li>
<li><a href="/food-and-drink/">Food &amp; Drink</a></li>
<li><a href="/edition/news-story--14-.htm">Wine Reviews</a></li>
			<li><a href="/wine/region/okanagan-valley/">Wine Maps</a></li>
<li><a href="/edition/news-story--24-.htm">Campus Life Okanagan</a></li>
			<li><a href="/edition/news-story--49-.htm">Campus Life Kamloops</a></li>
<li><a href="https://bctransit.com/" target="_blank" rel="noopener">Bus Schedule</a></li>
			<li><a href="https://ylw.kelowna.ca/passengers/arrivals" target="_blank" rel="noopener">YLW Arrive</a> / <a href="https://ylw.kelowna.ca/passengers/departures" target="_blank" rel="noopener">Depart</a></li>
			<li><a href="/kelownacouncil/">Kelowna Council</a></li>
			<li><a href="/edition/news-story--967-.htm">Crime Stoppers</a></li>
<li><a href="https://classifieds.castanet.net/flyers/">Flyers</a></li>
</ul>
<div style="clear:both"></div>
		</div>
</div>
		</div>
	</li>
	<li id="sfWeather">
		<a href="/weather/">Weather</a>
		<div class="sf-mega">
<div class="sf-mega-frame">
		<div class="sf-mega-section"> 
		<ul>
		<li><a href="/weather/Kelowna">Kelowna</a></li>
		<li><a href="/weather/Penticton">Penticton</a></li>
		<li><a href="/weather/Vernon">Vernon</a></li>
		<li><a href="/weather/Salmon-Arm">Salmon Arm</a></li>
		<li><a href="/weather/Kamloops">Kamloops</a></li>
		<li><a href="/weather/Vancouver">Vancouver</a></li>
		</ul>
		</div>
</div>
		</div>
	</li> 
</ul>
</div>
<div style="clear:both"></div>
	
<script type="text/javascript">
if (sfPage) { $('#'+sfPage).addClass("current"); }
$("#hdrbuttons a").click(function(){$.get("/ybclick.php?name="+$(this).attr('id'));});
$(".mhsform").submit(function(e){e.preventDefault();var _this=$(this);$.ajax("/ybclick.php?name="+_this.attr('name')).then(function(resp) {_this.unbind('submit').submit();})});
</script>
</div>
	<div id="content">
		<div id="hdad">
			<div id="hdpromo">
<div style="width:230px;height:90px;border-radius:7px;overflow:hidden"><a href="https://www.castanet.net/cgi-bin2/stats/clickcounter.cgi?id=190263&amp;cid=276902&amp;region=700" rel="nofollow" target="_blank"><img src="https://x.castanet.net/WiseGuysDevelopments/22-03/display/VIPContest-PR1.jpg" height="90" width="230" alt="190263"/></a></div>			</div>
			<div id="hdright">
<div style="width:728px;height:90px;border-radius:7px;overflow:hidden"><a href="https://www.castanet.net/cgi-bin2/stats/clickcounter.cgi?id=189731&amp;cid=276037&amp;region=314" rel="nofollow" target="_blank"><img src="https://x.castanet.net/Rockets/22-03/display/KelownaRockets-RSG-Castanet-Mar18-728x90px.gif" height="90" width="728" alt="189731"/></a></div>			</div>
			<div class="crow"></div>
		</div>
		<div class="crow"></div>
		<div id="lnews">
<div id="newsheader">Penticton&nbsp;&nbsp;</div>
<div class="newsstory" itemscope itemtype="https://schema.org/NewsArticle">
<h1 class="newsheadlinefull" itemprop="headline">RDOS mosquito prevention program expanding to cover Princeton, Keremeos and Naramata</h1><h2 class="newsheadline hasfull" itemprop="alternativeHeadline">Mosquito program expands</h2><div class="byline"><a href="/reporter/Casey-Richardson" itemscope itemprop="author" itemtype="https://schema.org/Person"><span itemprop="name">Casey Richardson</span></a> - <span itemprop="datePublished" datetime="2022-03-17T12:05:00">Mar 17, 2022 / 12:05 pm</span><span class="storyid"> | Story: 363198</span></div>
<div itemprop="articleBody">
<div class="gallery" id="photo3582713">
<div class="gallery_img"><img height="446" src="/content/2022/3/screen_shot_2020-04-15_at_4.13.57_pm_p3452579_p3582713.jpg" width="640" />
<div class="photo_credit">Photo: Randy McGuire</div>

<div class="photo_cutline" style="width:635px">RDOS mosquito spraying focuses on standing water areas</div>
</div>
</div>

<p>Mosquito control is heading towards a full regional service for 2023 throughout the entire Regional District of Okanagan-Similkameen, adding in Princeton, Keremeos and Naramata. </p>

<p>The RDOS Mosquito Control Program (MCP) works to limit the potential of widespread nuisance mosquitos, targeting known mosquito sites with a naturally-occurring granular bacterial larvicide which, when applied to water, kills mosquitoes and biting black flies at their larval stage but does not harm any other insects or animals.</p>

<p>Throughout March to September, over 400 sites are monitored throughout the South Okanagan-Similkameen, not including Princeton, Keremeos and Naramata. </p>

<p>In the past, cost apportionment for the mosquito control service was based on a value-added three year average of time spent in each participating area, on improvements only.</p>

<p>During the 2021 budget discussions, the fairness of this method was questioned and a motion was brought forward to discuss an expansion to a regional service. </p>

<p>This changed moves all properties to pay the same rate per $1000 depending on their assessment. </p>

<p>&ldquo;For about $700,000 property. It would cost $3.44 for the program for a year and put a perspective on it. A large coffee and donut at Tim Hortons is $3.36,&rdquo; Lisa Bloomfield ,RDOS Manager of Engineering said during Thursday&rsquo;s meeting. </p>

<p>Challenges with the current systems leave areas with a highly variable tax requisition rate every year.  </p>

<p>&ldquo;Of course in Area G we certainly support the option, just because of the fair and equitable addressing issue around the fact that mosquitoes don&#39;t see borders,&rdquo; Tim Roberts, director for rural Keremeos and Hedley explained. </p>

<p>Naramata director Karla Kozakevich noted she was also in agreement with expanding to a regional service, even if her area hasn&rsquo;t seen much of a mosquito problem themselves. </p>

<p>&ldquo;We&rsquo;ve all traveled to different parts of the region and we appreciate when we go for hikes or wine tasting or whatever in other communities that mosquitoes are being controlled there. So I think a full regional service for the entire RDOS is the fairest approach. We all benefit,&rdquo;Summerland Director Doug Holmes noted. </p>

<p>&ldquo;I probably spend more on mosquito repellent for my family and my children than this will cost us in the year,&rdquo; Ron Obirek, the Okanagan Falls area director added. </p>

<p>The motion passed for establishing a full regional service, with one director opposed. </p>

<p>Moving forward, the RDOS will need to prepare an amended bylaw and bring it to the board for three readings. The amendment bylaw will be then sent to the Inspector of Municipalities for approval.</p>

<p> </p>

<div class="gallery" id="photo3582714">
<div class="gallery_img hdgallery"><img class="large_overlay" height="243" limg="/content/2022/3/large/screen_shot_2022-03-17_at_12.03.45_pm_p3582714.jpg" src="/content/2022/3/screen_shot_2022-03-17_at_12.03.45_pm_p3582714.jpg" width="640" />
<div class="photo_credit">Photo: Contributed</div>
</div>
</div>
</div>
</div>
<div class="contentfooter">
<p class="backhome"><a href="/">Back to Homepage</a></p>
<a class="sfoot1" href="/contactus/report_typo.php?story=363198" target="_blank" rel="nofollow"><span>Typos</span></a><a class="sfoot2" href="/contactus/news-tips.php"><span>News Tips</span></a><a class="sfoot3" href="https://forums.castanet.net/"><span>Forums</span></a>
<div class="addthis_toolbox addthis_default_style addthis_32x32_style storyshare" addthis:url="https://www.castanet.net/news/Penticton/363198/RDOS-mosquito-prevention-program-expanding-to-cover-Princeton-Keremeos-and-Naramata" addthis:title="RDOS mosquito prevention program expanding to cover Princeton, Keremeos and Naramata - Penticton News" addthis:description="Mosquito control is heading towards a full regional service for 2023 throughout the entire Regional District of Okanagan-Similkameen, adding in Princeton, Keremeos and Naramata. " style="height:44px">
<a class="addthis_button_facebook"></a>
<a class="addthis_button_twitter"></a>
<a class="addthis_button_email"></a>
<a class="addthis_counter addthis_bubble_style"></a>
</div>
<div class="newsletter">
<div class="sfoot4">
<p>Must-Read Stories</p>
<span>Get all the day's most vital news with our newsletter, sent every weekday.</span>
</div>
<div class="mc_embed_signup">
<form action="https://glaciermedia.us5.list-manage.com/subscribe/post?u=cca0520b5e122304ac86be48e&amp;id=be97587725" method="post" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
<input type="email" value="" name="EMAIL" class="required email" placeholder="Enter Email Address" required />
<div style="position:absolute;left:-5000px" aria-hidden="true"><input type="text" name="b_cca0520b5e122304ac86be48e_be97587725" tabindex="-1" value="" /></div>
<input type="submit" value="Sign Me Up!" name="subscribe" class="button" />
</form>
</div>
</div>
</div>
<div class="crow"></div>
<div class="crow"></div><br/><br/>
<a href="/news/Penticton/" id="newsarchive">More Penticton News</a><br/><br/>
		</div>
<div id="rnews">
<div style="width:300px;height:250px;border-radius:7px;overflow:hidden"><a href="https://www.castanet.net/cgi-bin2/stats/clickcounter.cgi?id=190424&amp;cid=277207&amp;region=315" rel="nofollow" target="_blank"><img src="https://x.castanet.net/prospects/0/CoOperators-Ad-MR1B.gif" height="250" width="300" alt="190424"/></a></div><div class="recent-title">RECENT STORIES</div><div class="recent-news"><ul id="body1">
<li><a href='/edition/news-story-363202-4-.htm#363202'><div class="recent-img" style="background-image:url(/content/2022/3/thumb/363202_0.jpg);"></div><div class='recent-info'><span class='recent-headline'>Reaching out to refugees</span><span class='recent-sub'>Newfoundland - 12:35 pm</span></div></a></li>
<li><a href='/edition/news-story-363201-2-.htm#363201'><div class="recent-img" style="background-image:url(/content/2022/3/thumb/363201_0.jpg);"></div><div class='recent-info'><span class='recent-headline'>$4M in grants to businesses</span><span class='recent-sub'>Vernon - 12:28 pm</span></div></a></li>
<li><a href='/edition/news-story-363199-3-.htm#363199'><div class="recent-img" style="background-image:url(/content/2022/3/thumb/363199_0.jpg);"></div><div class='recent-info'><span class='recent-headline'>Helping youth out of care</span><span class='recent-sub'>BC - 12:21 pm</span></div></a></li>
<li><a href='/edition/news-story-363198-21-.htm#363198'><div class="recent-img" style="background-image:url(/content/2022/3/thumb/363198_0.jpg);"></div><div class='recent-info'><span class='recent-headline'>Mosquito program expands</span><span class='recent-sub'>Okanagan-Similkameen - 12:05 pm</span></div></a></li>
<li><a href='/edition/news-story-363197-63-.htm#363197'><div class="recent-img" style="background-image:url(/content/2022/3/thumb/363197_0.jpg);"></div><div class='recent-info'><span class='recent-headline'>Rise location rises above</span><span class='recent-sub'>Sponsored Content - 12:01 pm</span></div></a></li>
</ul><a class='recent-morelink' href='/'>More Top Stories &gt;</a></div>
<div class="crow"></div>
<br/><br/>
<div class="quicklinks"><span class="qlheader">Real Estate</span><div class='feature_line'><div id='feature_left'><a class="feat_link" href="https://classifieds.castanet.net/details/perfect_for_first_time_buyers/4641113/"><img src="https://c.castanet.net/img/218/4641113-1-1.jpg" alt="4641113" width="80" height="54" class="feat_img"/></a></div>
<div class="feat_details">137-495 All Star Court<br>
2 bedrooms 1 baths <br>
$350,000<br><a class="feat_link" href="https://classifieds.castanet.net/details/perfect_for_first_time_buyers/4641113/">more details</a><br></div><div class="clear"></div></div>
</div>
<div style="width:300px;height:250px;border-radius:7px;overflow:hidden"><a href="https://www.castanet.net/cgi-bin2/stats/clickcounter.cgi?id=188691&amp;cid=274022&amp;region=316" rel="nofollow" target="_blank"><img src="https://x.castanet.net/OkanaganCollege/22-02/display/OkanaganCollege-CSWinter-MR1.gif" height="250" width="300" alt="188691"/></a></div><br/><br/>
<br/><br/>
<div style="text-align:center">
<a href="/cdn-cgi/l/email-protection#513f3426221132302225303f34257f3f34256e2224333b3432256c1f3426220e053821"><img src="/img/newstips.jpg" alt="Send us your News Tips!" /></a><br/>
</div>
<br/><br/>
<div style="width:300px;height:600px;border-radius:7px;overflow:hidden"><a href="https://www.castanet.net/cgi-bin2/stats/clickcounter.cgi?id=189743&amp;cid=276048&amp;region=564" rel="nofollow" target="_blank"><img src="https://x.castanet.net/MissionHill/22-03/display/MissionHillFamilyEstates-WomensDay-HP1.jpg" height="600" width="300" alt="189743" loading="lazy"/></a></div>		
<br/><br/>
<div id="featuredpet">
<h2>Penticton SPCA Featured Pet</h2>
<a href="/adopt-a-pet/details/36010" style="width:300px;display:inline-block;text-align:center"><img src="/content/spca/thumbs/360620.jpg" alt="Sushi" width="128" height="128"/></a><br/>
<a href="/adopt-a-pet/details/36010" class="petname">Sushi</a>
<a class="petshelter" href="/adopt-a-pet/search/Area/2/">Penticton SPCA &gt;</a>
</div>
<br/><br/>
<div style="width:300px;height:600px;border-radius:7px;overflow:hidden"><a href="https://www.castanet.net/cgi-bin2/stats/clickcounter.cgi?id=188405&amp;cid=273284&amp;region=838" rel="nofollow" target="_blank"><img src="https://x.castanet.net/KondolasHometownFurniturePenticton/22-02/display/Kondolas-Hometown-MattressSale-HP1.gif" height="600" width="300" alt="188405" loading="lazy"/></a></div><br/><br/>

	<div class="ttlatest-container"><div class="ttlatest_head"><a href="https://thetango.net/"><img src="/images/logo_white.png" alt="TheTango.net" width="170" height="90"/></a></div><div class="thetango_latest" style="border-top:0px none"><div class="tango_first"><div class="tango_view">
    <a href="https://thetango.net/2022/03/17/a-husky-in-her-element/"><img src="https://thetango.net/wp-content/uploads/2022/03/a-husky-in-her-element-400x260.jpg" alt="A Husky in her element" width="400" height="260" style="height:auto" loading="lazy"></a>
    </div>
        <a class="tango-item" style="min-height:60px" href="https://thetango.net/2022/03/17/a-husky-in-her-element/"><h2>A Husky in her element</h2><div class="cat-links">Must Watch | March 17, 2022</div></a></div><a class="tango-item ti-lower" href="https://thetango.net/2022/03/17/pup-springs-out-of-her-harness/"><div style="background:url(https://thetango.net/wp-content/uploads/2022/03/pup-springs-out-of-her-harness-400x260.jpg);width:75px;height:75px;float:right;background-size:cover;background-position:center" alt="" loading="lazy"></div><h2>Pup springs out of her harness</h2><div class="cat-links">Must Watch | March 17, 2022</div></a><a class="tango-item ti-lower" href="https://thetango.net/2022/03/17/happy-st-patricks-day-2/"><div style="background:url(https://thetango.net/wp-content/uploads/2022/03/Screen-Shot-2022-03-17-at-9.03.03-AM.png);width:75px;height:75px;float:right;background-size:cover;background-position:center" alt="" loading="lazy"></div><h2>Happy St. Patrick's Day!</h2><div class="cat-links">Galleries | March 17, 2022</div></a><a class="tango-item ti-lower" href="https://thetango.net/2022/03/17/sam-smith-is-recording-a-new-album/"><div style="background:url(https://thetango.net/wp-content/uploads/2022/03/sam_smith_is_recording_a_new_album-400x260.jpg);width:75px;height:75px;float:right;background-size:cover;background-position:center" alt="" loading="lazy"></div><h2>Sam Smith is recording a new album</h2><div class="cat-links">Music | March 17, 2022</div></a><a class="tango-item ti-lower" href="https://thetango.net/2022/03/17/baby-mean-muggin/"><div style="background:url(https://thetango.net/wp-content/uploads/2022/03/baby-mean-muggin-400x260.jpg);width:75px;height:75px;float:right;background-size:cover;background-position:center" alt="" loading="lazy"></div><h2>Baby mean muggin'</h2><div class="cat-links">Must Watch | March 17, 2022</div></a>
        </div>
    </div>
	<br/><br/>
<div style="width:300px">
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script src='https://securepubads.g.doubleclick.net/tag/js/gpt.js'>
googletag.pubads().definePassback('/4326737/atex_GNG-BC_site_section_subsection_bigbox_S1_Castanet', [[300, 250], [300, 300]]).display();
</script>
</div>
<div class="quicklinks">
<span class="qlheader">South Okanagan Quick Links</span>
<a class="ql-related-links" href="https://www.penticton.ca" target="_blank">City of Penticton</a><br/>
<a class="ql-related-links" href="https://www.visitpenticton.com" target="_blank">Visit Penticton</a><br/>
<a class="ql-related-links" href="https://www.bctransit.com/south-okanagan-similkameen/home" target="_blank">Penticton Transit</a><br/>
<a class="ql-related-links" href="https://discovernaramata.com/" target="_blank">Discover Naramata</a><br/>
<a class="ql-related-links" href="https://www.okfalls.net/" target="_blank">Okanagan Falls</a><br/>
<a class="ql-related-links" href="https://www.oliver.ca/" target="_blank">Town of Oliver</a><br/>
<a class="ql-related-links" href="https://www.osoyoos.ca/" target="_blank">Town of Osoyoos</a><br/>
<a class="ql-related-links" href="https://www.keremeos.ca/" target="_blank">Town of Keremeos</a><br/>
<a class="ql-related-links" href="https://www.interiorhealth.ca/" target="_blank">Interior Health</a><br/>
<a class="ql-related-links" href="https://www.okanagan.bc.ca/campuses/Penticton-Campus" target="_blank">Okanagan College</a><br/>
<a class="ql-related-links" href="https://www.rdos.bc.ca/" target="_blank">Regional District Okanagan-Similkameen</a><br/>
<a class="ql-related-links" href="https://www.penticton.org/" target="_blank">Penticton &amp; Wine Country Chamber</a><br/>
<a class="ql-related-links" href="https://forums.castanet.net/viewforum.php?f=24">Penticton Discussion Forum</a><br/>				
<a class="ql-related-links" href="https://www.summerland.ca/" target="_blank">District of Summerland</a><br/>
<a class="ql-related-links" href="https://www.summerlandchamber.com/" target="_blank">Summerland Chamber &amp; Tourism</a><br/>	
<a class="ql-related-links" href="https://www.sd67.bc.ca/" target="_blank">School District 67 - Okanagan Skaha</a><br/>
<a class="ql-related-links" href="https://www.sd53.bc.ca/" target="_blank">School District 53 - Okanagan Similkameen </a><br/>
<a class="ql-related-links" href="https://www.orl.bc.ca/" target="_blank">Okanagan Regional Library</a><br/>	
</div>
<div style="margin:40px 0 40px 0;text-align:center;color:#000"><a href="https://rtdnacanada.com/"><img src="/img/RTNDA.jpg" alt="Castanet Proud Member of RTNDA Canada" width="300" height="115" loading="lazy"/></a></div>
<div id="sticky"><div style="width:300px;height:600px;border-radius:7px;overflow:hidden"><a href="https://www.castanet.net/cgi-bin2/stats/clickcounter.cgi?id=185442&amp;cid=267891&amp;region=936" rel="nofollow" target="_blank"><img src="https://x.castanet.net/FarmingKarma/21-10/display/FarmingKarma-Spirit-HP1.gif" height="600" width="300" alt="185442" loading="lazy"/></a></div></div>
</div>
		<div class="crow"></div>
<div style="width:728px;height:90px"><div style="width:728px;height:90px;border-radius:7px;overflow:hidden"><a href="https://www.castanet.net/cgi-bin2/stats/clickcounter.cgi?id=189396&amp;cid=275333&amp;region=794" rel="nofollow" target="_blank"><img src="https://x.castanet.net/Fh&amp;p Lawyers/22-03/display/FHP-Castanet-BusinessLaw-Mar2022-728x90.gif" height="90" width="728" alt="189396"/></a></div></div>
<div id="ftbot">
<div id="bftleft">
&copy; 2022 Castanet.net
<ul>
<li><a href="/homepage/" onclick="this.style.behavior='url(#default#homepage)';this.setHomePage('https://www.castanet.net/');">Make Castanet Your Homepage</a></li>
<li><a href="/contactus/news-tips.php">News Tips</a></li>
<li><a href="/advertise/">Advertising</a></li>
<li><a href="/contactus/">Contact Us</a></li>
</ul>
</div>
<div id="bftright">
</div>
<div class="crow"></div>
</div>
	</div>
</div>
</div>

<div id="backtotop"><a href="#" class="totop" title="Top of Page"></a><a href="#" class="homebtn" title="Home Page"></a></div>
<script>
$(document).ready(function() {
$('.popupVideo').magnificPopup({
disableOn: 700,
type: 'iframe',
mainClass: 'mfp-fade',
removalDelay: 160,
preloader: false,
fixedContentPos: false
});
});
function getCookie(name) {
	var re = new RegExp(name + "=([^;]+)");
	var value = re.exec(document.cookie);
	return (value != null) ? unescape(value[1]) : '0';
}

var winheight=0;
function flyout(el){
	fo_menu=$(el).parent().children('ul');
	if(winheight==0 ||winheight!=$(window).height()){
		$(fo_menu).css('top', '-100px');
		winheight=$(window).height();
	}
	fo_height=$(fo_menu).outerHeight();
	fo_bottom=($(fo_menu).offset().top + fo_height-$(window).scrollTop());
	if($(window).height()<fo_bottom){
		newtop=(fo_bottom-$(window).height()+105)*-1;
		$(fo_menu).css('top', newtop + 'px');
	}
}

$('a.taphover').on("touchstart", function (e) {
    "use strict"; //satisfy the code inspectors
	var link = $(this); //preselect the link

    if (link.hasClass('hover')) {
	return true;
    } else {
	 link.addClass("hover");
	flyout(link);
	$('a.taphover').not(this).removeClass("hover");
	e.preventDefault();
	return false;
    }
});
</script>
<script type="text/javascript" src="/js/main1o.js"></script>
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=castanet" async="async"></script>
<script type="text/javascript">if (navigator.userAgent.match(/iPhone/i) || navigator.userAgent.match(/iPad/i) || navigator.userAgent.match(/iPod/i) || navigator.userAgent.match(/Android/i) || navigator.userAgent.match(/BlackBerry/i)) {
var isPad=true;
var sticky_class="stick_pad";
var sticky_offset=15;
}else{ 
var isPad=false;
var sticky_class="stick";
var sticky_offset=90;
}
$(window).bind("load", function() {
	if($("#lnews").height()<=$("#rnews").height()) return;
	var s = $("#sticky");
	var pos = s.position();
	var p_height=$(document).height();
	var ad_height=s.height();
	$(window).scroll(function() {
		p_height=$(document).height();
		var windowpos = $(window).scrollTop();
		if(windowpos+ad_height+200>p_height-100){
			max_top=p_height-200-ad_height-10;
			s.css({"position":"absolute", "top":max_top+"px"})
			s.removeClass(sticky_class);
		}else{
			if ((windowpos+sticky_offset)>=pos.top) {
				s.css({"position":"", "top":""})
				s.addClass(sticky_class);
			} else {
				s.removeClass(sticky_class);
			}
		}
	});
});
$.fn.isOnScreen = function(){
var win = $(window);
var viewport = {
top : win.scrollTop(),
left : win.scrollLeft()
};
viewport.right = viewport.left + win.width();
viewport.bottom = viewport.top + win.height();

var bounds = this.offset();
bounds.right = bounds.left + this.outerWidth();
bounds.bottom = bounds.top + this.outerHeight();

return (!(viewport.right < bounds.left || viewport.left > bounds.right || viewport.bottom < bounds.top || viewport.top > bounds.bottom));
};
</script>
</body>
</html>
