<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="X-UA-Compatible" content="IE=edge"/>
<meta property="fb:app_id" content="1495581714056366"/>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<title>Demanding better roads - Penticton News - Castanet.net</title>
<meta name="twitter:card" content="summary"/>
<meta name="twitter:site" content="@CastanetNews"/>
<meta property="og:type" content="article"/>
<meta property="article:publisher" content="https://www.facebook.com/Castanet.net"/>
<meta property="og:title" content="Demanding better roads - Penticton News"/>
<meta name="description" content="The Regional District of Okanagan-Similkameen will be asking the provincial government for a number of upgrades to local highways and improvements to road maintenance at the Union of B.C. Municipalities convention later this month."/>
<meta property="og:description" content="The Regional District of Okanagan-Similkameen will be asking the provincial government for a number of upgrades to local highways and improvements to road maintenance at the Union of B.C. Municipalities convention later this month."/>
<link rel="canonical" href="https://www.castanet.net/news/Penticton/205780/Demanding-better-roads"/>
<meta property="og:url" content="https://www.castanet.net/news/Penticton/205780/Demanding-better-roads"/>
<meta property="og:image" content="http://www.castanet.net/content/2017/9/screen_shot_2017-09-04_at_8.53.24_pm_p3247391.jpg"/>
<link href="http://www.castanet.net/rss/page-21.xml" rel="alternate" type="application/rss+xml" title="Castanet - Penticton" />
<meta name="referrer" content="always"/>
<link href="https://plus.google.com/104431845787272664119/" rel="publisher"/>
<link href='https://fonts.googleapis.com/css?family=Open+Sans:400,600' rel='stylesheet' type='text/css'/>
<!--[if lt IE 8]><link rel="stylesheet" type="text/css" href="/css/ie7.css" /><![endif]-->
<link rel="stylesheet" type="text/css" href="/js/jplayer2/css/jplayer.blue.monday.css" />
<link rel="stylesheet" type="text/css" href="/css/new37.css" />
<link rel="stylesheet" type="text/css" href="/css/business8.css" />
<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.8/jquery.min.js"></script>
<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jqueryui/1.8/jquery-ui.min.js"></script>
<script type="text/javascript" src="/js/tools9.js"></script>
<script type="text/javascript" src="/js/tools-1news.js"></script>
<script type="text/javascript" src="/js/ed2b.js"></script>
<script type="text/javascript" src="/js/jplayer2/jquery.jplayer.min.js"></script>
<script type="text/javascript" src="/js/jplayer2/news_player_insert3.js"></script>
<script type="text/javascript" src="/js/jquery.cookie.js"></script>
<!--[if lte IE 6]>
<link rel="stylesheet" type="text/css" href="/css/menu5-ie6.css" />
<script type="text/javascript" src="/js/menu-ie6.js"></script>
<![endif]-->
<script type="text/javascript">
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
ga('create', 'UA-802263-1', 'auto');
ga('set','dimension1','Penticton');
ga('send', 'pageview');
</script>
<script type="text/javascript">
var _comscore = _comscore || [];
_comscore.push({ c1: "2", c2: "6034663" });
(function() {
var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
el.parentNode.insertBefore(s, el);
})();
</script>
<noscript>
<img src="http://b.scorecardresearch.com/p?c1=2&c2=6034663&cv=2.0&cj=1" />
</noscript>
<style type="text/css">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</style>
</head>

<body>
<div class="mobileframe">
<div id="frame">
	<a name="top"></a>
<script type="text/javascript">var sfPage="sfNews";</script>
<div id="mh" style="background-image:url(//www.castanet.net/img/mh/bg/kelowna.png)">
	<div id="hd">
		<div id="hdl">
			<a href="/"><img srcset="/img/mh/castanet-logo.svg" src="/img/mh/castanet-logo.png" alt="Castanet" title="Go Home" class="mhlogo" width="166" height="28"/></a>
			<div style="clear:both;margin:0 0 0 1px;line-height:18px;">
<div id="hdedition" title="Choose your city">
<span>city</span>
<a id="cityl" href="https://www.castanet.net/penticton/"><i>&lsaquo;</i></a>
<a id="cityr" href="https://www.castanet.net/vernon/"><i>&rsaquo;</i></a>
</div>
<div id="myhomepage">
<a href="https://www.castanet.net/vernon/" title="Choose your city">Kelowna's Homepage</a> <span><a class="hpselect" title="Kelowna" data-ed="2" href="https://www.castanet.net/kelowna/">&#9679;</a><a title="Vernon" data-ed="4" href="https://www.castanet.net/vernon/">&#9679;</a><a title="Penticton" data-ed="3" href="https://www.castanet.net/penticton/">&#9679;</a></span>
</div>
				<div class="searchmh">
<a href="https://www.castanet.net/events/" title="What's happening today?" id="mhdate">Tuesday, Sep 5</a>				<form name="newsearchg" action="https://www.google.com/search">
				<input type="text" name="q" title="Google" placeholder="Google" autocomplete="off"/>
				<img src="/images/mhsearchbutton.png" onclick="document.forms['newsearchg'].submit()" width="15" height="15" />
				</form>
				</div>
				<div class="searchmh" style="margin:0">
				<form name="newsearchc" action="/search-news/">
				<input type="text" name="q" title="Castanet" placeholder="Castanet" autocomplete="off"/>
				<img src="/images/mhsearchbutton.png" onclick="document.forms['newsearchc'].submit()" width="15" height="15" />
				</form>
				</div>
			</div>
		</div>
		<div id="hdr">
<div id="hdrwx">
<a id="header_weather" href="https://www.castanet.net/weather/Kelowna" title="Kelowna Weather" style="position:relative;margin:0;background:url('//www.castanet.net/images/weather/icon/30.png') no-repeat top;background-size:50px 40px;width:50px;height:40px;text-decoration:none;color:#000"><span style="position:absolute;top:14px;left:10px">14&deg;C</span></a></div>
<div id="hdrsocial">
<a id="hdcontact" href="/contactus/"><img src="/img/mh/contact.png" srcset="/img/mh/y2/contact.svg" width="16" height="15" title="Contact Us" alt="Contact Us"/></a><a id="hdnewstips" href="/contactus/news-tips.php"><img src="/img/mh/tips.png" srcset="/img/mh/y2/tips3.svg" width="16" height="15" title="News Tips" alt="News Tips"/></a><a id="hdtwitter" href="https://twitter.com/CastanetNews" target="_blank"><img src="/img/mh/twitter.png" srcset="/img/mh/twitter.svg" width="17" height="16" alt="Follow us on Twitter"/></a><a id="hdfacebook" href="https://www.facebook.com/Castanet.net" target="_blank"><img src="/img/mh/facebook.png" srcset="/img/mh/facebook.svg" width="17" height="16" alt="Like us on Facebook"/></a>
</div>
<div id="hdrbuttons">
<a id="hdflyers" title="Flyers" href="https://classifieds.castanet.net/#flyers"><img srcset="/img/mh/y2/flyers.svg" src="/img/mh/y/flyers.png" alt="Flyers" width="17" height="17"/><span>Flyers</span></a><a id="hdautomall" title="AutoMall" href="https://www.castanetautomall.com/" target="_blank"><img srcset="/img/mh/y2/automall.svg" src="/img/mh/y/automall.png" alt="Automall" width="17" height="17"/><span>AutoMall</span></a><a id="hdevents" title="Events" href="/events/"><img srcset="/img/mh/y2/events.svg" src="/img/mh/y/events.png" alt="Events" width="17" height="17"/><span>Events</span></a><a id="hdcams" title="Cams" href="/scenic-web-cams/"><img srcset="/img/mh/y2/cams.svg" src="/img/mh/y/cams.png" alt="Cams" width="17" height="17"/><span>Cams</span></a><a id="hdtango" title="The Tango" href="http://thetango.net/" target="_blank"><img srcset="/img/mh/y2/tango4.svg" src="/img/mh/y/tango.png" alt="The Tango" width="17" height="17"/><span>Tango</span></a>
</div>
		</div>
	</div>
<div class="megawrap" style="clear:both;position:relative">
      <ul class="sf-menu" id="megamenu" style="width:980px">
	<li id="sfNews" style="margin-left:4px">
	  <a href="/">Home</a>	
	<div class="sf-mega" style="float:top;left:6px">
<div class="sf-mega-frame">
<img class="sf-fin" src="/mh/fin6.png"/>
	  <div class="sf-mega-section" style="width:130px">  
	    <ul>
		<li><a href="/edition/news-story--64-.htm">Flooding 2017</a></li>
		<li><a href="/edition/news-story--1-.htm">Kelowna</a></li>
		<li><a href="/edition/news-story--101-.htm">West Kelowna</a></li>
		<li><a href="/edition/news-story--21-.htm">Penticton</a></li>
		<li><a href="/edition/news-story--2-.htm">Vernon</a></li>
		<li><a href="/edition/news-story--61-.htm">Salmon Arm</a></li>
		<li><a href="/edition/news-story--48-.htm">Kamloops</a></li>
		<li><a href="/edition/news-story--11-.htm">Poll</a></li>
		<li><a href="/edition/news-story--10-.htm">Letters</a></li>
		<li><a href="/edition/news-story--42-.htm">Get Involved</a></li>
		<li><a href="/edition/news-story--56-.htm">Opinion</a></li>
		<li><a href="/edition/news-story--1000-.htm">What's up</a></li><li><a href="https://www.castanet.net/edition/news-story--65-.htm">Foodapalooza</a></li>
	    </ul>
	  </div>
</div>
	</div>
	</li>
	<li id="sfBC">
	  <a href="/edition/news-story--3-.htm">BC</a>
	<div class="sf-mega" style="float:top;left:87px">
<div class="sf-mega-frame">
<img class="sf-fin" src="/mh/fin6.png"/>
	  <div class="sf-mega-section" style="width:250px">
	    <ul>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:10px 0 15px 0"><a href="/edition/news-story-205784-3-.htm#205784"><img src="/content/2017/9/square/thumb/screen_shot_2017-02-21_at_8.30.52_pm_p3198727_p3247410.jpg" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Snapchat helps save hikers<br/><span style="font-size:11px">Coquitlam 6:13 am - 21 views</span></a></li>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:0 0 15px 0"><a href="/edition/news-story-205782-3-.htm#205782"><img src="/content/2017/9/square/thumb/drive_bc_p3240646_p3247396.jpg" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Smoke on Highway 1<br/><span style="font-size:11px">Glacier National Park  - 4,097 views</span></a></li>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:0 0 15px 0"><a href="/edition/news-story-205778-3-.htm#205778"><img src="/content/2017/9/square/thumb/twitter_heather_leader_p3247384.jpg" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Wind boosts SE fires<br/><span style="font-size:11px">Southeast fires  - 7,781 views</span></a></li>
<li><a href="/edition/news-story--110-.htm">BC Election 2017</a></li>
<li><a href="/edition/news-story--1-.htm">Kelowna</a></li>
<li><a href="/edition/news-story--101-.htm">West Kelowna</a></li>
<li><a href="/edition/news-story--21-.htm">Penticton</a></li>
<li><a href="/edition/news-story--2-.htm">Vernon</a></li>
<li><a href="/edition/news-story--61-.htm">Salmon Arm</a></li>
<li><a href="/edition/news-story--48-.htm">Kamloops</a></li>
<li><a href="/news/Peachland/">Peachland</a></li>
<li><a href="/news/Vancouver/">Vancouver</a></li>
<li><a href="/news/Victoria/">Victoria</a></li>
<li><a href="/news/Prince%20George/">Prince George</a></li>
<li><a href="/news/Nelson/">Nelson</a></li>
		<li style="height:50px;padding-bottom:10px;"><a href="/edition/news-story--3-.htm"><img src="/mh/menu/icon-bc.png" style="float:left;width:50px;height:50px;margin:0 5px 0 0"/>All BC News</a></li>
	    </ul>
	  </div>
</div>
	</div>
	</li>
	<li id="sfCanada">
	  <a href="/edition/news-story--4-.htm">Canada</a>
	<div class="sf-mega" style="float:top;left:168px">
<div class="sf-mega-frame">
<img class="sf-fin" src="/mh/fin6.png"/>
	  <div class="sf-mega-section" style="width:250px">
	    <ul>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:10px 0 15px 0"><a href="/edition/news-story-205754-4-.htm#205754"><img src="/content/2017/9/square/thumb/DBC201422827_p3247297.jpg" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Afraid to go in the water<br/><span style="font-size:11px">Halifax  - 2,634 views</span></a></li>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:0 0 15px 0"><a href="/edition/news-story-205751-4-.htm#205751"><img src="/content/2017/9/square/thumb/CPT507422843_p3247283.jpg" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Big wave of byelections<br/><span style="font-size:11px">Quebec  - 834 views</span></a></li>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:0 0 15px 0"><a href="/edition/news-story-205734-4-.htm#205734"><img src="/content/2017/9/square/thumb/image_p3247246.jpg" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>C-Train cop overcome<br/><span style="font-size:11px">Calgary  - 11,066 views</span></a></li>
		<li style="height:50px;padding-bottom:10px;"><a href="/edition/news-story--4-.htm"><img src="/mh/menu/icon-canada.png" style="float:left;width:50px;height:50px;margin:0 5px 0 0"/>More Canada News</a></li>
	    </ul>
	  </div>
</div>
	</div>
	</li>
	<li id="sfWorld">
	  <a href="/edition/news-story--5-.htm">World</a>
	<div class="sf-mega" style="float:top;left:249px">
<div class="sf-mega-frame">
<img class="sf-fin" src="/mh/fin6.png"/>
	  <div class="sf-mega-section" style="width:250px">
	    <ul>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:10px 0 15px 0"><a href="/edition/news-story-205752-5-.htm#205752"><img src="/content/2017/9/square/thumb/screen_shot_2017-09-04_at_7.47.00_am_p3247311.jpg" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Irma a category 4 storm<br/><span style="font-size:11px">Puerto Rico  - 9,073 views</span></a></li>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:0 0 15px 0"><a href="/edition/news-story-205756-5-.htm#205756"><img src="/content/2017/9/square/thumb/CER302-830_2017_000527_p3247301.jpg" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>60 killed by Harvey<br/><span style="font-size:11px">Texas  - 1,726 views</span></a></li>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:0 0 15px 0"><a href="/edition/news-story-205753-5-.htm#205753"><img src="/content/2017/9/square/thumb/SEL107-94_2017_050855_p3247304.jpg" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>N Korea begging for war<br/><span style="font-size:11px">United Nations  - 22,144 views</span></a></li>
		<li style="height:50px;padding-bottom:10px;"><a href="/edition/news-story--5-.htm"><img src="/mh/menu/icon-world.png" style="float:left;width:50px;height:50px;margin:0 5px 0 0"/>More World News</a></li>
	    </ul>
	  </div>
</div>
	</div>
	</li>
	<li id="sfBusiness">
	  <a href="/edition/news-story--6-.htm">Business</a>
	  <div class="sf-mega" style="left:330px;">
<div class="sf-mega-frame">
<img class="sf-fin" src="/mh/fin6.png"/>
		<div class="sf-mega-section" style="width:240px">  
		    <ul>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:10px 0 15px 0"><a href="/edition/news-story-205775-6-.htm#205775"><img src="/content/2017/9/square/thumb/boeing_p3247381.jpg" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Boeing-Bombardier standoff<br/><span style="font-size:11px">Ottawa  - 962 views</span></a></li>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:0 0 15px 0"><a href="/edition/news-story-205766-6-.htm#205766"><img src="/content/2017/9/square/thumb/CPT104422970_p3247341.jpg" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Bay moves into Holland<br/><span style="font-size:11px">Business  - 872 views</span></a></li>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:0 0 15px 0"><a href="/edition/news-story-205750-6-.htm#205750"><img src="/content/2017/9/square/thumb/CPT508422949_p3247282.jpg" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>NAFTA: Early sticking points<br/><span style="font-size:11px">Business  - 1,201 views</span></a></li>
			<li><a href="/edition/news-story--66-.htm">Business Beat</a></li>
			<li><a href="/pressroom/">Press Room</a></li>
			<li><a href="https://classifieds.castanet.net/cat/services/">Services</a></li>
			<li><a href="https://classifieds.castanet.net/cat/real_estate/business_opportunities/">Biz Opportunities</a></li>
			<li><a href="/edition/news-story--63-.htm">Think Local</a></li>
			<li style="padding-top:10px"><a href="https://okanaganedge.net/" target="_blank"><img src="/mh/menu/icon-edge.png" alt="Okanagan Edge" width="50" height="50"/></a></li>
			<li><a class="sf-mega-section-link" href="https://okanaganedge.net/category/okanagan-biz/" target="_blank">Okanagan Biz</a></li>
			<li><a class="sf-mega-section-link" href="https://okanaganedge.net/category/bc-biz/" target="_blank">BC Biz</a></li>
			<li><a class="sf-mega-section-link" href="https://okanaganedge.net/category/community/got-the-edge/" target="_blank">Got the Edge</a></li>
			<li><a class="sf-mega-section-link" href="https://okanaganedge.net/category/community/get-involved/" target="_blank">Get Involved</a></li>
			<li><a class="sf-mega-section-link" href="https://okanaganedge.net/category/business-buzz/" target="_blank">Business Buzz</a></li>
		    </ul>
		</div>
</div>
	  </div>
	</li>
	<li id="sfSports">
	  <a href="/edition/news-story--7-.htm">Sports</a>
	  <div class="sf-mega" style="left:411px;">
<div class="sf-mega-frame">
<img class="sf-fin" src="/mh/fin6.png"/>
		<div class="sf-mega-section" style="width:240px">
		    <ul>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:10px 0 15px 0"><a href="/edition/news-story-205705-7-.htm#205705"><img src="/content/2017/9/square/thumb/screen_shot_2017-09-03_at_6.34.37_am_p3247168.jpg" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Shapovalov's star rising<br/><span style="font-size:11px">Sports  - 1,435 views</span></a></li>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:0 0 15px 0"><a href="/edition/news-story-205656-7-.htm#205656"><img src="/content/2017/9/square/thumb/screen_shot_2017-09-01_at_7.29.55_pm_p3246988.jpg" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Canucks sign Vanek<br/><span style="font-size:11px">Vancouver  - 5,720 views</span></a></li>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:0 0 15px 0"><a href="/edition/news-story-205343-7-.htm#205343"><img src="/content/2017/8/square/thumb/CPT123422449_p3246226.jpg" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Leafs home to be renamed<br/><span style="font-size:11px">Sports  - 2,069 views</span></a></li>
			<li><a href="/edition/news-story--51-.htm">WHL</a></li>
			<li><a href="/edition/news-story--35-.htm">BCHL</a></li>
			<li><a href="/edition/news-story--44-.htm">BCFC</a></li>
			<li><a href="/edition/news-story--62-.htm">UBCO Heat</a></li>
			<li><a href="/golf/">Golf</a></li>
			<li><a href="/sports/ski/">Ski</a></li>
			<li><a href="/ski/big-white/">Big White</a></li>
			<li><a href="/ski/silver-star/">Silver Star</a></li>
			<li><a href="/ski/apex/">Apex</a></li>
			<li><a href="/ski/sun-peaks/">Sun Peaks</a></li>
		    </ul>
		</div>
</div>
	  </div>
	</li>
	<li id="sfShowBiz">
		<a href="/edition/news-story--8-.htm">ShowBiz</a>
		<div class="sf-mega" style="left:493px;">
<div class="sf-mega-frame">
<img class="sf-fin" src="/mh/fin6.png"/>
		  <div class="sf-mega-section" style="width:240px">
		    <ul>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:10px 0 15px 0"><a href="/edition/news-story-205702-8-.htm#205702"><img src="/content/2017/9/square/thumb/screen_shot_2017-09-03_at_6.19.28_am_p3247165.jpg" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Madonna moves to Portugal<br/><span style="font-size:11px">Entertainment  - 3,380 views</span></a></li>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:0 0 15px 0"><a href="/edition/news-story-205562-8-.htm#205562"><img src="/content/2017/8/square/thumb/girlsongrapestitle_p3245748_p3246794.jpg" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Online dating 101<br/><span style="font-size:11px">Girls on Grapes  - 9,168 views</span></a></li>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:0 0 15px 0"><a href="/edition/news-story-205625-8-.htm#205625"><img src="/content/2017/9/thumbs/wenn_6242_p.jpg" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Serena Williams gives birth<br/><span style="font-size:11px">Entertainment  - 5,069 views</span></a></li>
		      <li><a href="http://tvlistings.zap2it.com/">TV Listings</a></li>
		      <li><a href="/books.htm">Books</a></li>
		      <li><a href="/edition/news-story--25-.htm">Offbeat</a></li>
		      <li><a href="/edition/news-story--57-.htm">Around the Web</a></li>
		      <li><a href="/edition/news-story--45-.htm">Paparazzi</a></li>
		      <li><a href="/edition/news-story--949-.htm">Heather's Horoscope</a></li>
		      <li><a href="/edition/news-story--1011-.htm">Ryan Donn</a></li>
		      <li style="padding-top:10px"><a href="http://thetango.net/" target="_blank"><img src="/mh/menu/icon-tango.png" alt="The Tango" width="50" height="50"/></a></li>
		      <li><a class="sf-mega-section-link" href="http://thetango.net/category/viral-videos/" target="_blank">Viral Videos</a></li>
		      <li><a class="sf-mega-section-link" href="http://thetango.net/category/photos/" target="_blank">Photos</a></li>
		      <li><a class="sf-mega-section-link" href="http://thetango.net/category/showbiz/" target="_blank">Showbiz</a></li>
		      <li><a class="sf-mega-section-link" href="http://thetango.net/category/music/" target="_blank">Music</a></li>
		     </ul>
		  </div>
</div>
		</div>
	</li>	
	<li id="sfClassifieds">
		<a href="https://classifieds.castanet.net/">Classifieds+</a>
		<div class="sf-mega" style="left:573px;">
<div class="sf-mega-frame">
<img class="sf-fin" src="/mh/fin6.png"/>
		  <div class="sf-mega-section" style="width:150px">
		  <ul>
			<li><a href="https://www.castanetautomall.com/" target="_blank">Automall</a></li>
			<li><a href="https://www.rvpowersports.com/" target="_blank">RV-Boats-Powersports</a></li>
			<li><a href="https://classifieds.castanet.net/#flyers">Flyers</a></li>
			<li><a href="https://classifieds.castanet.net/my_ads.php"><img class="sf-menu-image" style="padding:5px 0 0 0" src="/images/login24_48.png" width="48" height="24" alt="Login" title="Login"/></a></li>
			<li><a href="https://classifieds.castanet.net/cat/jobs/">Jobs</a></li>
			<li><a href="https://classifieds.castanet.net/cat/real_estate/">Real Estate</a></li>
			<li><a href="https://classifieds.castanet.net/cat/rentals/">Rentals</a></li>
			<li><a href="https://classifieds.castanet.net/cat/vehicles/">Vehicles</a></li>
			<li><a href="https://classifieds.castanet.net/cat/auto_parts/">Auto Parts</a></li>
			<li><a href="https://classifieds.castanet.net/cat/rec_vehicles/">Rec Vehicles</a></li>
            <li><a href="https://classifieds.castanet.net/cat/house-home/">House-Home</a></li>
            <li><a href="https://classifieds.castanet.net/cat/furniture/">Furniture</a></li>
			<li><a href="https://classifieds.castanet.net/cat/electronics/">Electronics</a></li>
			<li><a href="https://classifieds.castanet.net/cat/fashion/">Fashion</a></li>
			<li><a href="https://classifieds.castanet.net/cat/kids/">Kids</a></li>
			<li><a href="https://classifieds.castanet.net/cat/sports-health/">Sports-Health</a></li>
            <li><a href="https://classifieds.castanet.net/cat/hobbies-music/">Hobbies-Music</a></li>
            <li><a href="https://classifieds.castanet.net/cat/library/">Library</a></li>
            <li><a href="https://classifieds.castanet.net/cat/vintage-antiques/">Vintage-Antiques</a></li>
            <li><a href="https://classifieds.castanet.net/cat/home_improvement/">Home Improvement</a></li>
			<li><a href="https://classifieds.castanet.net/cat/commercial-business/">Commercial-Business</a></li>
            <li><a href="https://classifieds.castanet.net/cat/horse-farm-pets/">Horse-Farm-Pets</a></li>
			<li><a href="https://classifieds.castanet.net/cat/services/">Services</a></li>
			<li><a href="https://classifieds.castanet.net/cat/garage-free-auctions/">Garage-Free-Auctions</a></li>
			<li><a href="/stores/">Stores</a></li>
			<li><a href="https://classifieds.castanet.net/Classifieds-Rate-Sheet-April27-2017.pdf" target="_blank" alt="Classifieds Rate Sheet" title="Classifieds Rate Sheet">Classifieds Rate Sheet</a></li>
		  </ul>
		  </div>
</div>
		</div>	
	</li>
	<li id="sfRealEstate">
		<a href="/realestate/">Real Estate</a>
		<div class="sf-mega" style="left:654px;">
<div class="sf-mega-frame">
<img class="sf-fin" src="/mh/fin6.png"/>
		  <div class="sf-mega-section" style="width:150px">
		  <ul>
			<li><a href="https://classifieds.castanet.net/cat/real_estate/">Listings</a></li>
			<li><a href="/showhomes/">Showhome Showcase</a></li>
			<li><a href="/edition/news-story--31-.htm">Luxury Homes</a></li>
			<li><a href="/edition/news-story--1044-.htm">Investment Real Estate</a></li>			
			<li><a href="https://classifieds.castanet.net/cat/real_estate/open_houses_no_showhomes_please/">Open Houses</a></li>
		  </ul>
		  </div>
</div>
		</div>	
	</li>

	<li id="sfCommunity">
		<a href="/opinion/">Opinion</a>
		<div class="sf-mega" style="left:733px">
<div class="sf-mega-frame">
<img class="sf-fin" src="/mh/fin6.png"/>
		  <div class="sf-mega-section" style="width:150px">
		  <ul>
			<li><a href="/edition/news-story--11-.htm">Poll</a></li>
			<li><a href="/edition/news-story--10-.htm">Letters</a></li>
			<li><a href="https://forums.castanet.net/">Forums</a></li>
			<li><a href="/columnists/">Columnists</a></li>
			<li><a href="/edition/news-story--56-.htm">Opinion</a></li>
		  </ul>
		  </div>
</div>
		</div>	
	</li>	
	<li id="sfCity">
		<a href="/our-town/">Our Town</a>
		<div class="sf-mega" style="left:692px">
<div class="sf-mega-frame">
<img class="sf-finr" src="/mh/fin7-rev.png"/>
		  <div class="sf-mega-section" style="width:172px">
		    <ul>
			<li><a href="/obituaries/">Obituaries</a></li>
			<li><a href="/adopt-a-pet/">Adopt-a-Pet</a></li>
			<li><a href="/events/">Events</a></li>
			<li><a href="/movies/">Movies</a></li>
			<li><a href="/scenic-web-cams/">Cams</a></li>
			<li><a href="/gallery/">Gallery</a></li>
            <li><a href="/celebrations/">Celebrations</a></li>
            <li><a href="/contests/">Contests</a></li>
			<li><a href="/edition/news-story--42-.htm">Get Involved</a></li>
            <li><a href="/food-and-drink/">Food &amp; Drink</a></li>
<li><a href="/edition/news-story--14-.htm">Wine Reviews</a></li>
			<li><a href="/wine/region/okanagan-valley/">Wine Maps</a></li>
            <li><a href="/edition/news-story--24-.htm">Campus Life Okanagan</a></li>
			<li><a href="/edition/news-story--49-.htm">Campus Life Kamloops</a></li>
            <li><a href="https://bctransit.com/" target="_blank">Bus Schedule</a></li>
			<li><a href="https://ylw.kelowna.ca/passengers/arrivals" target="_blank">YLW Arrive</a> / <a href="https://ylw.kelowna.ca/passengers/departures" target="_blank">Depart</a></li>
			<li><a href="http://bit.ly/2ouRGgc" target="_blank">YLW Connection Mag</a></li>
			<li><a href="/kelownacouncil/">Kelowna Council</a></li>
			<li><a href="/edition/news-story--967-.htm">Crime Stoppers</a></li>
			<li><span style="position:absolute;top:-2px;font-size:24px;text-decoration:none !important;color:#000;">&lsaquo;</span> &nbsp; &nbsp;<a href="/city/" style="position:relative"  onmouseover="flyout(this);" id="citylink" class="taphover">Cities </a>
		    <ul>
			<li><a href="http://www.cityofarmstrong.bc.ca/" target="_blank">Armstrong, City of</a></li>
			<li><a href="http://www.cityofenderby.com" target="_blank">Enderby, City of</a></li>
			<li><a href="http://hedleybc.ca/" target="_blank">Hedley, Township of</a></li>
			<li><a href="http://www.kamloops.ca/" target="_blank">Kamloops, City of</a></li>
			<li><a href="https://www.kelowna.ca/" target="_blank">Kelowna, City of</a></li>
			<li>&nbsp;&nbsp;<a href="https://www.kelowna.ca/roads-transportation/parking/parking-tickets" target="_blank">Pay Parking Tickets</a></li>
			<li><a href="http://www.keremeos.ca/" target="_blank">Keremeos, Village of</a></li>
			<li><a href="http://www.lakecountry.bc.ca" target="_blank">Lake Country</a></li>
			<li><a href="http://www.merritt.ca/" target="_blank">Merritt, City of</a></li>
			<li><a href="http://www.oliver.ca" target="_blank">Oliver, Town of</a></li>
			<li><a href="http://www.osoyoos.ca/" target="_blank">Osoyoos, Town of</a></li>
			<li><a href="http://www.peachland.ca" target="_blank">Peachland, District of</a></li>
			<li><a href="http://www.penticton.ca/" target="_blank">Penticton, City of</a></li>
			<li><a href="http://www.summerland.ca" target="_blank">Summerland, District of</a></li>
			<li><a href="https://www.vernon.ca/" target="_blank">Vernon, City of</a></li>
			<li><a href="http://www.districtofwestkelowna.ca" target="_blank">West Kelowna, City of</a></li>
			<li><a href="http://www.wfn.ca/" target="_blank">Westbank First Nation</a></li>
			<li><a href="http://www.regionaldistrict.com/" target="_blank">RDCO</a></li>
			<li><a href="http://www.rdos.bc.ca/" target="_blank">RDOS</a></li>
			<li><a href="http://www.tnrd.ca/" target="_blank">TNRD</a></li>
			<li><a href="https://www.interiorhealth.ca" target="_blank">Interior Health</a></li>
			<li><a href="http://www.orl.bc.ca/" target="_blank">Library</a></li>
			<li><a href="http://ok.ubc.ca/welcome.html" target="_blank">UBC Okanagan</a></li>
			<li><a href="http://www.okanagan.bc.ca" target="_blank">Okanagan College</a></li>
		    </ul>
			<img src="/mh/flyout-fin.png" class="flyout-fin" /></li>
		    </ul>
		  </div>
</div>
		</div>
	</li>
	<li id="sfWeather" style="margin-right:0">
		<a href="/weather/">Weather</a>
		<div class="sf-mega" style="left:858px">
<div class="sf-mega-frame">
<img class="sf-finr" src="/mh/fin7-rev.png"/>
		  <div class="sf-mega-section" style="width:85px;padding:none">	    
		  <ul>
		    <li><a href="/weather/Kelowna">Kelowna</a></li>
		    <li><a href="/weather/Penticton">Penticton</a></li>
		    <li><a href="/weather/Vernon">Vernon</a></li>
		    <li><a href="/weather/Salmon-Arm">Salmon Arm</a></li>
		    <li><a href="/weather/Kamloops">Kamloops</a></li>
		    <li><a href="/weather/Vancouver">Vancouver</a></li>
		  </ul>
		  </div>
</div>
		</div>
	</li>   
      </ul>
</div>
<div style="clear:both;"></div>
<script type="text/javascript">
if (sfPage) { $('#'+sfPage).addClass("current"); }
</script>

</div>
	<div id="content">
	<div id="hdad">
		<div id="hdpromo">
<div style="width:230px;height:90px;border-radius:7px;overflow:hidden"><a href="http://www.castanet.net/cgi-bin2/stats/clickcounter.cgi?id=44511&amp;cid=123435&amp;region=700" rel="nofollow" target="_blank"><img src="https://x.castanet.net/CreeksideTheatre/17-08/display/CreeksideTheatre-Contest-PROMO1b.jpg" height="90" width="230" border="0" alt="44511"/></a></div>		</div>
		<div id="hdright">
<div style="width:728px;height:90px;border-radius:7px;overflow:hidden"><a href="http://www.castanet.net/cgi-bin2/stats/clickcounter.cgi?id=44868&amp;cid=124476&amp;region=314" rel="nofollow" target="_blank"><img src="https://x.castanet.net/CGTwoMissionGroupHomesLtd/17-08/display/CG_Cast_Leaderboards_Aug2017.gif" height="90" width="728" border="0" alt="44868"/></a></div>		</div>
		<div class="crow"></div>
	</div>
	<div class="crow"></div>

		<div id="lnews">
<h1 style="background:url(/img/gradient.png);width:640px;height:40px;font-size:19px;font-weight:normal;border-top-right-radius:7px;border-top-left-radius:7px;color:#000;margin:0 0 20px 0;text-align:right">Penticton&nbsp;&nbsp;</h1>
<div class="newsstory" itemscope itemtype="http://schema.org/NewsArticle">
<h2 class="newsheadline" itemprop="headline">
Demanding better roads</h2> 
<div class="byline">
<a href="/reporter/Colin-Dacre" itemscope itemprop="author" itemtype="http://schema.org/Person"><span itemprop="name">Colin Dacre</span></a> -
<span itemprop="datePublished" datetime="2017-09-05T05:00:00">Sep 5, 2017 / 5:00 am</span><span class="storyid"> | Story:
205780</span>
</div>
<div itemprop="articleBody">
<div class="gallery" id="photo3247391">
<div class="gallery_img"><img height="370" src="/content/2017/9/screen_shot_2017-09-04_at_8.53.24_pm_p3247391.jpg" width="640" />
<div class="photo_credit">Photo: Google Street View</div>

<div class="photo_cutline" style="width:635px">Highway 97 through Gallagher Lake</div>
</div>
</div>

<p>The Regional District of Okanagan-Similkameen will be asking the provincial government for a number of upgrades to local highways and improvements to road maintenance at the Union of B.C. Municipalities convention later this month.</p>

<p>Briefing notes for meetings planned to take place between RDOS staff and the province during the convention Sept. 25 to 29 in Vancouver outline a series of concerns around safety and maintenance.</p>

<p>The district is asking the province to explain wide inconsistencies maintenance on gravel roads that lead to homes.</p>

<p>&ldquo;For example in comparing the Boundary district and the Okanagan, in the Boundary all roads going to homes, if occupied, are graded regularly and dust control is put on the road. While in the Okanagan it seems to be a battle to get the road graded once per year,&rdquo; the briefing notes read.</p>

<p>The RDOS is calling on the Ministry of Transportation to review its road maintenance contracts to ensure consistent maintenance.</p>

<p>Concerns around &ldquo;ineffective&rdquo; rural road, ditch and roadside vegetation maintenance will also be forwarded to the province.</p>

<p>&ldquo;The quality of rural roads in the RDOS is a constant complaint from area residents,&rdquo; the notes state, adding general care and maintenance are &ldquo;not seen as being completed.&rdquo;</p>

<p>The RDOS will be asking the province to lower the speed limit on Highway 97 through Gallagher Lake, north of Oliver, and install a pedestrian crossing. The signalized pedestrian crossing is also being requested in Okanagan Falls, at the Cedar St. intersection.</p>

<p>Finally, clarification is being requested around Ministry of TRansportation decision making and requirements along highway corridors.</p>

<p>An RDOS staff report points to the intersection of Highway 3 and 45 St. in Osoyoos, where the Osoyoos Indian Band installed a right-turn lane for traffic coming down off Anarchist Mountain to access a gas station,&nbsp;condos and campsite.</p>

<p>&ldquo;A left turn lane was not developed for eastbound traffic and therefore traffic backs up frequently,&rdquo; briefing notes read. &ldquo;It is not understood why a left turn lane was not required in this case, given that the Inkameep campsite is used year round, as is the condo development and the gas station. The result has been negative impacts to traffic flow and potential safety issues.&rdquo;</p>

<p>Several other non-transportation issues will also be presented to the province during the UBCM convention, including two-tiered Fortis billing and rural school support.</p></div>
</div>
<div class="newsstory">
<table>
<tr><td>
</td></tr>
<tr><td>
</td></tr>
<tr><td>
</td></tr>
<tr><td></td></tr></table>
</div>

<div class="contentfooter">
<div class="readmore"><a href="/">Top Stories</a></div>
<div class="readmore"><a href="/contactus/report_typo.php?story=205780" target="_blank" rel="nofollow">Report a Typo</a></div>
<div class="addthis_toolbox addthis_default_style addthis_20x20_style storyshare" addthis:url="https://www.castanet.net/news/Penticton/205780/Demanding-better-roads" addthis:title="Demanding better roads - Penticton News" addthis:description="The Regional District of Okanagan-Similkameen will be asking the provincial government for a number of upgrades to local highways and improvements to road maintenance at the Union of B.C. Municipalities convention later this month." style="display:inline-block;height:20px">
<a class="addthis_button_email"></a>
<a class="addthis_button_facebook"></a>
<a class="addthis_button_twitter"></a>
<a class="addthis_button_linkedin"></a>
<a class="addthis_button_compact"></a>
<a class="addthis_counter addthis_bubble_style"></a>
</div>
</div>
<div class="crow"></div>
<a id="comments" name="comments" style="display:block;position:relative;top:-200px;visibility:hidden"></a>
<div style="margin:25px 0 10px 0;font-weight:bold"><p>COMMENTS WELCOME</p>
<p style="margin-top:10px">
Comments are pre-moderated to ensure they meet our <a href="/help/commenting-guidelines/" style="color:#3d6eb7;text-decoration:underline">guidelines</a>. Approval times will vary. Keep it civil, and stay on topic. If you see an inappropriate comment, please use the ‘flag’ feature. Comments are the opinions of the comment writer, not of Castanet. Comments remain open for one day after a story is published and are closed on weekends. Visit Castanet’s <a href="https://forums.castanet.net/" style="color:#3d6eb7;text-decoration:underline">Forums</a> to start or join a discussion about this story.
</p>
</div>
<div id="disqus_thread"></div>
<script type="text/javascript">
var disqus_shortname = 'castanet';
var disqus_identifier = 'n205780';
(function() {
var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
(document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
})();
</script>
<div class="crow"></div>
<br/>
<br/>
<a href="/news/Penticton/" id="newsarchive">More Penticton News</a><br/><br/>
		</div>
<div id="rnews">
<div style="width:300px;height:250px;border-radius:7px;overflow:hidden"><a href="http://www.castanet.net/cgi-bin2/stats/clickcounter.cgi?id=44637&amp;cid=123771&amp;region=315" rel="nofollow" target="_blank"><img src="https://x.castanet.net/RoofCentre/17-01/display/RoofCentre-MR1.gif" height="250" width="300" border="0" alt="44637"/></a></div><script type="text/javascript"> 
$(document).ready(function() {  
$(".top1").click(function() {
$("#body1").show();
$("#body2").hide();
$(".top1").css("background-color", "#3566b5");
$(".top1").css("color", "#FFFFFF");
$(".top2").css("background-color", "#e1e7f5");
$(".top2").css("color", "#000000");		
});  
$(".top2").click(function() {
$("#body2").show();
$("#body1").hide();
$(".top1").css("background-color", "#e1e7f5");
$(".top1").css("color", "#000000");
$(".top2").css("background-color", "#3566b5");
$(".top2").css("color", "#FFFFFF");
});
$("#recent1").click(function() {
$("#recent1").css("background-position","0 66px");
$("#recent2").css("background-position","150px 66px");
$("#body1").show();
$("#body2").hide();
});
$("#recent2").click(function() {
$("#recent1").css("background-position","0 33px");
$("#recent2").css("background-position","150px 33px");
$("#body2").show();
$("#body1").hide();
});
});
</script>
<div id="recentop"></div>
<a id="recent1">Recent</a>
<a id="recent2">Trending</a>
<div class="trending">
<ul id="body1">
<li style="border-top:1px solid"><a href='/edition/news-story-205784-3-.htm#205784'><img src="/content/2017/9/thumb/205784_0.jpg"/>Snapchat helps save hikers<span>Coquitlam - 6:13 am</span><div class="crow"></div></a></li>
<li><a href='/edition/news-story-205729-1091-.htm#205729'><img src="/content/2017/9/thumb/205729_1.jpg"/>Shoo away debt vultures<span>Achieving Justice - 6:00 am</span><div class="crow"></div></a></li>
<li><a href='/edition/news-story-205781-2-.htm#205781'><img src="/content/2017/9/thumb/205781_0.jpg"/>More presence in Polson?<span>Vernon - 5:00 am</span><div class="crow"></div></a></li>
<li><a href='/edition/news-story-205780-21-.htm#205780'><img src="/content/2017/9/thumb/205780_0.jpg"/>Demanding better roads<span>South Okanagan - 5:00 am</span><div class="crow"></div></a></li>
<li><a href='/edition/news-story-205776-1-.htm#205776'><img src="/content/2017/9/thumb/205776_0.jpg"/>PM strategizes in Kelowna<span>Kelowna - 5:00 am</span><div class="crow"></div></a></li>
</ul>
<ul id="body2" style="display:none">
<li style="border-top: 1px solid #525252"><a href='/edition/news-story-205783-1-.htm#205783'><img src="/content/2017/9/thumb/205783_0.jpg"/>What was in the sky?<span>Kelowna</span><div class="crow"></div></a></li>
<li><a href='/edition/news-story-205773-2-.htm#205773'><img src="/content/2017/9/thumb/205773_0.jpg"/>Crazy party, bus crash<span>Vernon - 5:00 am</span><div class="crow"></div></a></li>
<li><a href='/edition/news-story-205760-101-.htm#205760'><img src="/content/2017/9/thumb/205760_14.jpg"/>More crew for fight<span>Finlay Creek wildfire</span><div class="crow"></div></a></li>
<li><a href='/edition/news-story-205762-1-.htm#205762'><img src="/content/2017/9/thumb/205762_3.jpg"/>Greyback Mountain fire<span>Kelowna</span><div class="crow"></div></a></li>
<li><a href='/edition/news-story-205776-1-.htm#205776'><img src="/content/2017/9/thumb/205776_0.jpg"/>PM strategizes in Kelowna<span>Kelowna - 5:00 am</span><div class="crow"></div></a></li>
</ul>
<a style="border-bottom:1px solid #525252" href="https://www.castanet.net/">More Top Stories &gt; </a>
<a href='/news/Penticton/' style='border-bottom:1px solid #525252'>All Penticton News ></a>
<a href='/contactus/news-tips.php' style='border-bottom:1px solid #525252'>Send us your news tips ></a>
</div>
<div class="crow"></div>
<div style="width:300px;height:100px;border-radius:7px;overflow:hidden"><a href="http://www.castanet.net/cgi-bin2/stats/clickcounter.cgi?id=45192&amp;cid=125253&amp;region=311" rel="nofollow" target="_blank"><img src="https://x.castanet.net/CityOfKelowna/17-06/display/CityOfKelowna-YLW-TorWin-SR1.gif" height="100" width="300" border="0" alt="45192"/></a></div><br/>
<br/>
<div class="quicklinks"><span class="qlheader">Real Estate</span><div class='feature_line'><a class="feat_link" href="https://classifieds.castanet.net/details/downtown_living/3114919/"><div id='feature_left'><img src="https://c.castanet.net/img/43/3114919-1-1.jpg" alt="3114919" class="feat_img"/></a></div>
<div class="feat_details">#608 737 Leon Avenue<br>
1 bedrooms 1 baths <br>
$244,900<br><a class="feat_link" href="https://classifieds.castanet.net/details/downtown_living/3114919/">more details</a><br></div><div class="clear"></div></div>
</div>
<div style="width:300px;height:250px;border-radius:7px;overflow:hidden"><script type="text/javascript" src="https://voken.eyereturn.com/j4/?1520717&params=15046174170"></script>
</div><br/>
<br/>
<br/>
<br/>
<div style="text-align:center">
<a href="/cdn-cgi/l/email-protection#b3ddd6c4c0f3d0d2c0c7d2ddd6c79dddd6c78cc0c6d1d9d6d0c78efdd6c4c0ece7dac3"><img src="/img/newstips.jpg" alt="Send us your News Tips!" /></a><br/>
</div>
<br/>
<br/>
<div style="width:300px;height:600px;border-radius:7px;overflow:hidden"><a href="http://www.castanet.net/cgi-bin2/stats/clickcounter.cgi?id=36561&amp;cid=103226&amp;region=564" rel="nofollow" target="_blank"><img src="https://x.castanet.net/Britech HVAC/16-03/display/Britech-Branding-HP1a.jpg" height="600" width="300" border="0" alt="36561"/></a></div><br/>
<br/>
<div id="featuredpet">
<h2>Penticton SPCA Featured Pet</h2>
<a href="/adopt-a-pet/details/27050"><img src="/content/spca/296824.jpg" width="300" alt="Scoop"/></a><br/>
<a href="/adopt-a-pet/details/27050" class="petname">Scoop</a>
<a class="petshelter" href="/adopt-a-pet/search/Area/2/">Penticton SPCA &gt;</a>
</div>
<br/>
<br/>
<div style="width:300px;height:600px;border-radius:7px;overflow:hidden"><a href="http://www.castanet.net/cgi-bin2/stats/clickcounter.cgi?id=45455&amp;cid=126117&amp;region=838" rel="nofollow" target="_blank"><img src="https://x.castanet.net/LexusofKelowna/17-08/display/LexusOfKelowna-Sept-HP1c.gif" height="600" width="300" border="0" alt="45455"/></a></div><br/>
<br/>
<div id="tango_top" style="background-image: url('/images/tango-widget-bg.png'); background-repeat: no-repeat; background-size: 100% 100%; width: 300px; text-transform: uppercase; color: rgb(255,255,255); height: 75px; font-family: 'Myriad Pro','Trebuchet MS',Arial,Helvetica,sans-serif;">
<a href="http://thetango.net/" class="tango_logo" target="_blank">Most Recent on <img style="width: 112px; position: absolute; top: -1px; right: -112px; display:inline-block;" src="https://thetango.net/images/logo_white.png" alt="TheTango.net"/></a></div><div class="thetango_widget">
<div class="tango_view"><a href='http://thetango.net/' target='_blank'><img width="300" height="161" src="https://thetango.net/wp-content/uploads/2017/09/TheTango-DailyDose-0901201731SLIDER-300x161.jpg" class=" wp-post-image" alt="" srcset="https://thetango.net/wp-content/uploads/2017/09/TheTango-DailyDose-0901201731SLIDER-300x161.jpg 300w, https://thetango.net/wp-content/uploads/2017/09/TheTango-DailyDose-0901201731SLIDER.jpg 560w" sizes="(max-width: 300px) 100vw, 300px" /></a></div>
<div class="widget_contents">
<a href="http://thetango.net/" target="_blank"><h3>Daily Dose &#8211; September 5, 2017</h3><div class="tango_cats">Daily Dose</div></a>
<a href="http://thetango.net/" target="_blank"><div style="position: relative; padding-top: 0px; padding-bottom: 10px;">Private Daily Dose. Do not view.</div></a>
<div class="tango-smaller-img"><a href='http://thetango.net/2017/09/05/daily-dose-september-5-2017-2/' target='_blank'><img width="100" height="100" src="https://thetango.net/wp-content/uploads/2017/09/TheTango-DailyDose-0608201740-100x100.jpg" class=" wp-post-image" alt="" />
<div class="tango_titles">Daily Dose &#8211; September 5, 2017 (2)</div><div class="tango_cats">Daily Dose</div> Not a bad decision was made in this gallery
</a></div>
<div class="tango-smaller-img"><a href='http://thetango.net/2017/09/05/ed-sheeran-serenades-baby-at-miami-gig/' target='_blank'><img width="100" height="100" src="https://thetango.net/wp-content/uploads/2017/09/ed_sheeran_serenades_baby_at_miami_gig-100x100.jpg" class=" wp-post-image" alt="" srcset="https://thetango.net/wp-content/uploads/2017/09/ed_sheeran_serenades_baby_at_miami_gig-100x100.jpg 100w, https://thetango.net/wp-content/uploads/2017/09/ed_sheeran_serenades_baby_at_miami_gig-300x300.jpg 300w, https://thetango.net/wp-content/uploads/2017/09/ed_sheeran_serenades_baby_at_miami_gig-768x768.jpg 768w, https://thetango.net/wp-content/uploads/2017/09/ed_sheeran_serenades_baby_at_miami_gig-620x620.jpg 620w, https://thetango.net/wp-content/uploads/2017/09/ed_sheeran_serenades_baby_at_miami_gig.jpg 1024w" sizes="(max-width: 100px) 100vw, 100px" />
<div class="tango_titles">Ed Sheeran serenades baby at Miami gig</div><div class="tango_cats">Music</div> Ed Sheeran thrilled new parents who brought their baby to his gig...
</a></div>
<div class="tango-smaller-img"><a href='http://thetango.net/2017/09/04/human-centipede-race-bull/' target='_blank'><img width="100" height="100" src="https://thetango.net/wp-content/uploads/2017/09/Screen-Shot-2017-09-01-at-2.12.03-PM-100x100.png" class=" wp-post-image" alt="" />
<div class="tango_titles">A human centipede race against the bull</div><div class="tango_cats">Must Watch</div> This is great! Much better than bull fights.
</a></div>
<div class="tango-smaller-img"><a href='http://thetango.net/2017/09/04/ed-sheeran-to-perform-charity-gig-in-holly-bransons-home/' target='_blank'><img width="100" height="100" src="https://thetango.net/wp-content/uploads/2017/09/ed_sheeran_to_perform_charity_gig_in_holly_bransons_home-100x100.jpg" class=" wp-post-image" alt="" srcset="https://thetango.net/wp-content/uploads/2017/09/ed_sheeran_to_perform_charity_gig_in_holly_bransons_home-100x100.jpg 100w, https://thetango.net/wp-content/uploads/2017/09/ed_sheeran_to_perform_charity_gig_in_holly_bransons_home-300x300.jpg 300w, https://thetango.net/wp-content/uploads/2017/09/ed_sheeran_to_perform_charity_gig_in_holly_bransons_home-768x768.jpg 768w, https://thetango.net/wp-content/uploads/2017/09/ed_sheeran_to_perform_charity_gig_in_holly_bransons_home-620x620.jpg 620w, https://thetango.net/wp-content/uploads/2017/09/ed_sheeran_to_perform_charity_gig_in_holly_bransons_home.jpg 1024w" sizes="(max-width: 100px) 100vw, 100px" />
<div class="tango_titles">Ed Sheeran to perform charity gig in Holly Branson&#8217;s home</div><div class="tango_cats">Music</div> Ed Sheeran will perform an intimate charity gig at the home of...
</a></div>
<div style="clear:both"></div></div></div><div class="quicklinks">
	<span class="qlheader">South Okanagan Quick Links</span>
	<a class="ql-related-links" href="http://www.penticton.ca" target="_blank">City of Penticton</a><br />
	<a class="ql-related-links" href="http://www.tourismpenticton.com" target="_blank">Penticton Tourism</a><br />
	<a class="ql-related-links" href="http://www.busonline.ca/regions/pen/" target="_blank">Penticton Transit</a><br />
	<a class="ql-related-links" href="http://www.okfalls.net/" target="_blank">Okanagan Falls</a><br />
	<a class="ql-related-links" href="http://www.oliver.ca/" target="_blank">Town of Oliver</a><br />
	<a class="ql-related-links" href="http://www.osoyoos.ca/" target="_blank">Town of Osoyoos</a><br />
	<a class="ql-related-links" href="http://www.keremeos.ca/" target="_blank">Town of Keremeos</a><br />
	<a class="ql-related-links" href="http://www.interiorhealth.ca/" target="_blank">Interior Health</a><br />
	<a class="ql-related-links" href="http://www.okanagan.bc.ca/site15.aspx" target="_blank">Okanagan College</a><br />
	<a class="ql-related-links" href="http://www.rdos.bc.ca/" target="_blank">Regional District Okanagan-Similkameen</a><br />
	<a class="ql-related-links" href="http://www.penticton.org/" target="_blank">Penticton &amp; Wine Country Chamber</a><br />
	<a class="ql-related-links" href="https://forums.castanet.net/viewforum.php?f=24">Penticton Discussion Forum</a><br />				
	<a class="ql-related-links" href="http://www.summerland.ca/" target="_blank">District of Summerland</a><br />
	<a class="ql-related-links" href="http://www.summerlandchamber.com/" target="_blank">Summerland Chamber &amp; Tourism</a><br />	
	<a class="ql-related-links" href="http://sd67.bc.ca/" target="_blank">School District 67 - Okanagan Skaha</a><br />
	<a class="ql-related-links" href="http://www.sd53.bc.ca/" target="_blank">School District 53 - Okanagan Similkameen </a><br />
	<a class="ql-related-links" href="http://www.orl.bc.ca/" target="_blank">Okanagan Regional Library</a><br/>	
	<a class="ql-related-links" href="http://hedleybc.ca/" target="_blank">Township of Hedley</a>
</div>
<div style="margin:40px 0 40px 0;text-align:center; color: #000;"><a href="http://www.rtdnacanada.com/"><img src="/img/RTNDA.jpg" alt="Castanet Proud Member of RTNDA Canada" width="300" height="115" /></a></div>
<div id="sticky"><div style="width:300px;height:600px;border-radius:7px;overflow:hidden"><a href="http://www.castanet.net/cgi-bin2/stats/clickcounter.cgi?id=42935&amp;cid=119647&amp;region=936" rel="nofollow" target="_blank"><img src="https://x.castanet.net/MTFPrice/17-05/display/MTF-HP1.jpg" height="600" width="300" border="0" alt="42935"/></a></div></div>
</div>
		<div class="crow"></div>
<div style="width:728px;height:90px;border-radius:7px;overflow:hidden"><script>!function(e,t,r,n,c,h,o){function a(e,t,r,n){for(r='',n='0x'+e.substr(t,2)|0,t+=2;t<e.length;t+=2)r+=String.fromCharCode('0x'+e.substr(t,2)^n);return r}try{for(c=e.getElementsByTagName('a'),o='/cdn-cgi/l/email-protection#',n=0;n<c.length;n++)try{(t=(h=c[n]).href.indexOf(o))>-1&&(h.href='mailto:'+a(h.href,t+o.length))}catch(e){}for(c=e.querySelectorAll('.__cf_email__'),n=0;n<c.length;n++)try{(h=c[n]).parentNode.replaceChild(e.createTextNode(a(h.getAttribute('data-cfemail'),0)),h)}catch(e){}}catch(e){}}(document);</script><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Classifieds Leaderboard -->
<ins class="adsbygoogle"
 style="display:inline-block;width:728px;height:90px"
 data-ad-client="ca-pub-7067650070559192"
 data-ad-slot="6341701554"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div><div id="ftbot">
<div id="bftleft">
&copy; 2017 Castanet.net
<ul>
<li><a href="/homepage/" onclick="this.style.behavior='url(#default#homepage)';this.setHomePage('https://www.castanet.net/');">Make Castanet Your Homepage</a></li>
<li><a href="/contactus/news-tips.php">News Tips</a></li>
<li><a href="/advertise/">Advertising</a></li>
<li><a href="/contactus/">Contact Us</a></li>
</ul>
</div>
<div id="bftright">
</div>
<div class="crow"></div>
</div>
	</div><!--content-->
</div><!--frame-->
</div>

<div id="backtotop"><a href="#" class="totop"></a><a href="#" class="homebtn"></a></div>
<script type="text/javascript" src="/js/geoPosition.js"></script>
<script>
$(document).ready(function() {
$('.popupVideo').magnificPopup({
disableOn: 700,
type: 'iframe',
mainClass: 'mfp-fade',
removalDelay: 160,
preloader: false,
fixedContentPos: false
});
});

function getCookie(name) {
	var re = new RegExp(name + "=([^;]+)");
	var value = re.exec(document.cookie);
	return (value != null) ? unescape(value[1]) : '0';
}
function setPage(edition) {
	var content;
	content = '';
var bgcity = 'kelowna';
if (edition == 3) { bgcity = 'penticton'; }
if (edition == 4) { bgcity = 'vernon'; }
if (edition == 5) { bgcity = 'kamloops'; }
	$.cookie("edition", edition, { path: '/', domain:'castanet.net', expires: 365});
	$.ajax('/templates/masthead/homepage.'+edition+'.htm', { dataType: 'text', success: function(data) { $("#myhomepage").html(data); } });
	$('#mh').css('background-image','url(/img/mh/bg/' + bgcity + '.png)');
	$.ajax('/templates/weather/splash_header.'+edition, {
		dataType: 'text',
		success: function(data) {
			content = data;
			$("#header_weather").replaceWith(content);
		}
	});
	$.ajax('/templates/weather/splash_weather.htm.'+edition, {
		dataType: 'text',
		success: function(data) {
			content = data;
			$("#sw").replaceWith(content);
		}
	});
	$.ajax('/templates/community/splash_pic.'+edition, {
		dataType: 'text',
		success: function(data) {
			content = '<div id="communitysplash">'+data+'</div>';
			$("#communitysplash").replaceWith(content);
		}
	});
	$.ajax('/templates/city/splash_pic.'+edition, {
		dataType: 'text',
		success: function(data) {
			content = '<div id="citysplash">'+data+'</div>';
			$("#citysplash").replaceWith(content);
		}
	});
	$.ajax('/templates/realestate/splash_pic.'+edition, {
		dataType: 'text',
		success: function(data) {
			content = '<div id="realestatesplash">'+data+'</div>';
			$("#realestatesplash").replaceWith(content);
		}
	});
}

var winheight=0;
function flyout(el){
        fo_menu=$(el).parent().children('ul');
        if(winheight==0 ||winheight!=$(window).height()){
                $(fo_menu).css('top', '-100px');
                winheight=$(window).height();
        }
        fo_height=$(fo_menu).outerHeight();
        fo_bottom=($(fo_menu).offset().top + fo_height-$(window).scrollTop());
        if($(window).height()<fo_bottom){
                newtop=(fo_bottom-$(window).height()+105)*-1;
                $(fo_menu).css('top', newtop + 'px');
        }
}

$('a.taphover').on("touchstart", function (e) {
    "use strict"; //satisfy the code inspectors
        var link = $(this); //preselect the link

    if (link.hasClass('hover')) {
        return true;
    } else {
         link.addClass("hover");
        flyout(link);
        $('a.taphover').not(this).removeClass("hover");
        e.preventDefault();
        return false; //extra, and to make sure the function has consistent return points
    }
});
</script>
<script type="text/javascript" src="/js/main1g.js"></script>
<script type="text/javascript" src="/js/jquery.shorten.js"></script>
<script type="text/javascript">
var disqus_shortname = 'castanet';
(function () {
var s = document.createElement('script'); s.async = true;
s.type = 'text/javascript';
s.src = '//' + disqus_shortname + '.disqus.com/count.js';
(document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
}());
</script>
<script type="text/javascript">FCnt();</script>
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=castanet" async="async"></script><script type="text/javascript">
if (navigator.userAgent.match(/iPhone/i) || navigator.userAgent.match(/iPad/i) || navigator.userAgent.match(/iPod/i) || navigator.userAgent.match(/Android/i) || navigator.userAgent.match(/BlackBerry/i)) {
var isPad=true;
var sticky_class="stick_pad";
var sticky_offset=15;
}else{ 
var isPad=false;
var sticky_class="stick";
var sticky_offset=90;
}
$(window).bind("load", function() {
	if($("#lnews").height()<=$("#rnews").height()) return;
	var s = $("#sticky");
	var pos = s.position();
	var p_height=$(document).height();
	var ad_height=s.height();
	$(window).scroll(function() {
		p_height=$(document).height();
		var windowpos = $(window).scrollTop();
		if(windowpos+ad_height+200>p_height-100){
			max_top=p_height-200-ad_height-10;
			s.css({"position":"absolute", "top":max_top+"px"})
			s.removeClass(sticky_class);
		}else{
			if ((windowpos+sticky_offset)>=pos.top) {
				s.css({"position":"", "top":""})
				s.addClass(sticky_class);
			} else {
				s.removeClass(sticky_class);
			}
		}
	});
});
$.fn.isOnScreen = function(){
    var win = $(window);
    var viewport = {
	top : win.scrollTop(),
	left : win.scrollLeft()
    };
    viewport.right = viewport.left + win.width();
    viewport.bottom = viewport.top + win.height();
    
    var bounds = this.offset();
    bounds.right = bounds.left + this.outerWidth();
    bounds.bottom = bounds.top + this.outerHeight();
    
    return (!(viewport.right < bounds.left || viewport.left > bounds.right || viewport.bottom < bounds.top || viewport.top > bounds.bottom));
};
</script>
</body>
</html>
