<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>
<meta http-equiv="X-UA-Compatible" content="IE=edge"/>
<meta property="fb:app_id" content="1495581714056366"/>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<title>Snow piling up in Kelowna as crews brace for another dump - Kelowna News - Castanet.net</title>
<meta name="twitter:card" content="summary_large_image"/>
<meta name="twitter:site" content="@CastanetNews"/>
<meta property="og:type" content="article"/>
<meta property="article:publisher" content="https://www.facebook.com/Castanet.net"/>
<meta property="article:content_tier" content="free"/>
<meta property="article:opinion" content="false"/>
<meta property="og:title" content="Snow piling up in Kelowna as crews brace for another dump - Kelowna News"/>
<meta property="article:tag" content="Vehicles & Transportation"/>
<meta name="description" content="Weary snow clearing crews in Central Okanagan communities are gearing up for another dump."/>
<meta property="og:description" content="Weary snow clearing crews in Central Okanagan communities are gearing up for another dump."/>
<script src="/cdn-cgi/apps/head/xWaxO5HBfKVD5Vfk-QoB64H5pT8.js"></script><link rel="canonical" href="https://www.castanet.net/news/Kelowna/356184/Snow-piling-up-in-Kelowna-as-crews-brace-for-another-dump"/>
<meta property="og:url" content="https://www.castanet.net/news/Kelowna/356184/Snow-piling-up-in-Kelowna-as-crews-brace-for-another-dump"/>
<meta property="og:image" content="https://www.castanet.net/content/2022/1/1640730689-img_20211228_133129223_mp._p3569873.jpg"/>
<link href="https://www.castanet.net/rss/page-1.xml" rel="alternate" type="application/rss+xml" title="Castanet - Kelowna" />
<meta name="referrer" content="always"/>
<link href='https://fonts.googleapis.com/css?family=Open+Sans:400,600&amp;display=swap' rel='stylesheet' type='text/css'/>
<!--[if lt IE 8]><link rel="stylesheet" type="text/css" href="/css/ie7.css" /><![endif]-->
<link rel="stylesheet" type="text/css" href="/css/new77.css" />
<link rel="stylesheet" type="text/css" href="/css/business8.css" />
<style type="text/css">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</style>
<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.8/jquery.min.js"></script>
<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jqueryui/1.8/jquery-ui.min.js"></script>
<script type="text/javascript" src="/js/tools-2news.js"></script>
<script type="text/javascript" src="/js/jquery.cookie.js"></script>
<script type="text/javascript">
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
ga('create', 'UA-802263-1', 'auto');
ga('send', 'pageview');
</script>
<script type="text/javascript">
var _comscore = _comscore || [];
_comscore.push({ c1: "2", c2: "6034663" });
(function() {
var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
s.src = "https://sb.scorecardresearch.com/cs/6034663/beacon.js";
el.parentNode.insertBefore(s, el);
})();
</script>
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
window.googletag = window.googletag || {cmd: []};
googletag.cmd.push(function() {
 googletag.defineSlot('/4326737/Local_Raffle_Castanet', [[300, 250], 'fluid'], 'div-gpt-ad-1623945318670-0').addService(googletag.pubads());
 googletag.pubads().enableSingleRequest();
 googletag.pubads().collapseEmptyDivs();
 googletag.enableServices();
});
</script>
</head>

<body>
<noscript><img src="https://sb.scorecardresearch.com/p?c1=2&amp;c2=6034663&amp;cv=3.6.0&amp;cj=1" alt="" /></noscript>
<div class="mobileframe">
<div id="frame">
	<a id="top"></a>
<script type="text/javascript">var sfPage="sfNews";</script>
<div id="mh" class="kelowna-mh">
	<div id="hd">
		<div id="hdl">
			<a href="/"><img srcset="/img/mh/castanet-logo.svg" src="/img/mh/castanet-logo.png" alt="Castanet" title="Go Home" class="mhlogo" width="225" height="37"/></a>
		</div>
		<div id="hdr">
<div id="hdrwx">
<a id="header_weather" href="https://www.castanet.net/weather/Kelowna" title="Kelowna Weather" style="position:relative;margin:0;background:url('//www.castanet.net/images/weather/icon/33.png') no-repeat top;background-size:50px 40px;width:50px;height:40px;text-decoration:none;color:#000"><span style="position:absolute;top:14px;left:10px">-13&deg;C</span></a></div>
<div style="float:right;margin-right:5px"><a href="https://castanetapparel.com/?utm_source=castanet.net&amp;utm_medium=masthead" target="_blank" rel="noopener"><img src="/img/mh/Castanet-Apparel.png" width="98" height="40" alt="Castanet Apparel"/></a></div>
		</div>

<div style="clear:both;margin:0 0 0 5px;line-height:18px">
<div id="hdedition" title="Choose your city">
<span>city</span>
<a id="cityl" href="https://www.castanetkamloops.net/">&lsaquo;</a>
<a id="cityr" href="https://www.castanet.net/vernon/">&rsaquo;</a>
</div>
<div id="myhomepage">
<a href="https://www.castanet.net/vernon/" title="Choose your city">Kelowna's Homepage</a> <span><a class="hpselect" title="Kelowna" href="https://www.castanet.net/kelowna/">&#9679;</a><a title="Vernon" href="https://www.castanet.net/vernon/">&#9679;</a><a title="Penticton" href="https://www.castanet.net/penticton/">&#9679;</a><a title="Kamloops" href="https://www.castanetkamloops.net/">&#9679;</a></span>
</div>
<div class="searchmh">
<a href="https://www.castanet.net/events/" title="What's happening today?" id="mhdate">Wednesday, Jan 5</a><form class="mhsform" name="newsearchg" action="https://www.google.com/search">
<input type="text" name="q" title="Google" placeholder="Google" autocomplete="off"/>
<input type="image" name="submit" src="/images/mhsearchbutton.png" style="width:15px;height:15px;position:absolute;top:0px;right:2px" alt="Submit"/>
</form>
</div>
<div class="searchmh" style="margin:0">
<form class="mhsform" name="newsearchc" action="/search-news/">
<input type="text" name="q" title="Castanet" placeholder="Castanet" autocomplete="off"/>
<input type="image" name="submit" src="/images/mhsearchbutton.png" style="width:15px;height:15px;position:absolute;top:0px;right:2px" alt="Submit"/>
</form>
</div>

<div id="hdrbuttons">
<a id="hdflyers" title="Flyers" href="https://classifieds.castanet.net/flyers/">Flyers</a><a id="hdautomall" title="AutoMall" href="https://www.castanetautomall.com/" target="_blank" rel="noopener">AutoMall</a><a id="hdevents" title="Events" href="/events/">Events</a><a id="hdcams" title="Cams" href="/scenic-web-cams/">Cams</a><a id="hdtango" title="The Tango" href="https://thetango.net/" target="_blank" rel="noopener">Tango</a>
</div>
</div>

	</div>
<div class="megawrap">
<ul class="sf-menu" id="megamenu">
	<li id="sfNews">
	<a href="/">Home</a>
	<div class="sf-mega">
<div class="sf-mega-frame">
	<div class="sf-mega-section">
	<ul class="sf2col">
<li><a href="/edition/news-story--1-.htm">Kelowna</a></li>
<li><a href="/edition/news-story--101-.htm">West Kelowna</a></li>
<li><a href="/edition/news-story--21-.htm">Penticton</a></li>
<li><a href="/edition/news-story--2-.htm">Vernon</a></li>
<li><a href="/edition/news-story--61-.htm">Salmon Arm</a></li>
<li><a href="/edition/news-story--48-.htm">Kamloops</a></li>
</ul>
<ul class="sf2col2">
<li><a href="/edition/news-story--11-.htm">Poll</a></li>
<li><a href="/edition/news-story--10-.htm">Letters</a></li>
<li><a href="/edition/news-story--42-.htm">Get Involved</a></li>
<li><a href="/opinion/">Opinion</a></li>
<li><a href="/edition/news-story--1000-.htm">What's up</a></li>
<li><a href="/edition/news-story--71-.htm">Coronavirus</a></li>
<li><a href="/covid19-resources/">COVID-19 Community Resources</a></li>
<li><a href="/ParadeOfLights/">Parade of Lights</a></li>
</ul>
<div style="clear:both"></div>
	</div>
</div>
	</div>
	</li>
	<li id="sfBC">
	<a href="/edition/news-story--3-.htm">BC</a>
	<div class="sf-mega">
<div class="sf-mega-frame">
	<div class="sf-mega-section">
	<ul>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:10px 0 15px 0"><a href="/edition/news-story-356168-3-.htm#356168"><img src="/content/2022/1/thumb/356168_0.jpg" alt="Story 356168" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>3,798 new cases, no deaths<br/><span style="font-size:11px">BC 2:52 pm - 14,525 views</span></a></li>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:0 0 15px 0"><a href="/edition/news-story-356157-3-.htm#356157"><img src="/content/2022/1/thumb/356157_1.jpg" alt="Story 356157" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Travel advisory issued<br/><span style="font-size:11px">BC Highways 2:38 pm - 9,012 views</span></a></li>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:0 0 15px 0"><a href="/edition/news-story-356154-3-.htm#356154"><img src="/content/2022/1/square/thumb/20220105150120-61d5fd7514dc8757aa0c4459jpeg_p3569820.jpg" alt="Story 356154" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Homeowners grant limit up<br/><span style="font-size:11px">BC 12:53 pm - 10,410 views</span></a></li>
</ul>
<ul class="sf2col">
<li><a href="/edition/news-story--1-.htm">Kelowna</a></li>
<li><a href="/edition/news-story--101-.htm">West Kelowna</a></li>
<li><a href="/edition/news-story--21-.htm">Penticton</a></li>
<li><a href="/edition/news-story--2-.htm">Vernon</a></li>
<li><a href="/edition/news-story--61-.htm">Salmon Arm</a></li>
<li><a href="/edition/news-story--48-.htm">Kamloops</a></li>
</ul>
<ul class="sf2col2">
<li><a href="/news/Peachland/">Peachland</a></li>
<li><a href="/news/Vancouver/">Vancouver</a></li>
<li><a href="/news/Victoria/">Victoria</a></li>
<li><a href="/news/Prince%20George/">Prince George</a></li>
<li><a href="/news/Nelson/">Nelson</a></li>
</ul>
<ul style="clear:both">
<li class="sf-menu-icon"><a href="/edition/news-story--3-.htm" class="bc-icon">All BC News</a></li>
	</ul>
	</div>
</div>
	</div>
	</li>
	<li id="sfCanada">
	<a href="/edition/news-story--4-.htm">Canada</a>
	<div class="sf-mega">
<div class="sf-mega-frame">
	<div class="sf-mega-section">
	<ul>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:10px 0 15px 0"><a href="/edition/news-story-356175-4-.htm#356175"><img src="/content/2022/1/square/thumb/20220105120156-61d5dbe90245fe752e6d414bjpeg_p3569788.jpg" alt="Story 356175" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Return party flight grounded<br/><span style="font-size:11px">Quebec 3:10 pm - 8,928 views</span></a></li>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:0 0 15px 0"><a href="/edition/news-story-356172-4-.htm#356172"><img src="/content/2022/1/square/thumb/2022010515014-61d5f9ec5068c3306a95dc59jpeg_p3569830.jpg" alt="Story 356172" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Iran snubs another deadline<br/><span style="font-size:11px">Canada 2:57 pm - 2,545 views</span></a></li>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:0 0 15px 0"><a href="/edition/news-story-356169-4-.htm#356169"><img src="/content/2022/1/square/thumb/20220105150144-61d60336a3dd3e88b383d78djpeg_p3569851.jpg" alt="Story 356169" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Wait for vaccine donations<br/><span style="font-size:11px">Canada 2:54 pm - 2,541 views</span></a></li>
<li class="sf-menu-icon"><a href="/edition/news-story--4-.htm" class="canada-icon">More Canada News</a></li>
	</ul>
	</div>
</div>
	</div>
	</li>
	<li id="sfWorld">
	<a href="/edition/news-story--5-.htm">World</a>
	<div class="sf-mega">
<div class="sf-mega-frame">
	<div class="sf-mega-section">
	<ul>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:10px 0 15px 0"><a href="/edition/news-story-356196-5-.htm#356196"><img src="/content/2022/1/thumb/356196_0.jpg" alt="Story 356196" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Fires could have been worse<br/><span style="font-size:11px">Colorado 5:06 pm - 355 views</span></a></li>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:0 0 15px 0"><a href="/edition/news-story-356188-5-.htm#356188"><img src="/content/2022/1/square/thumb/20220105180132-61d62b304f648c0f3dccf316jpeg_p3569870.jpg" alt="Story 356188" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>US prisons director resigning<br/><span style="font-size:11px">United States 4:23 pm - 387 views</span></a></li>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:0 0 15px 0"><a href="/edition/news-story-356187-5-.htm#356187"><img src="/content/2022/1/thumb/356187_0.jpg" alt="Story 356187" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Cops faked radio chatter<br/><span style="font-size:11px">Seattle 4:22 pm - 3,764 views</span></a></li>
<li class="sf-menu-icon"><a href="/edition/news-story--5-.htm" class="world-icon">More World News</a></li>
	</ul>
	</div>
</div>
	</div>
	</li>
	<li id="sfBusiness">
	<a href="/edition/news-story--6-.htm">Business</a>
	<div class="sf-mega">
<div class="sf-mega-frame">
		<div class="sf-mega-section">
		<ul>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:10px 0 15px 0"><a href="/edition/news-story-356173-6-.htm#356173"><img src="/content/2022/1/square/thumb/20220105130116-61d5e12d4f648c0f3dccd58ejpeg_p3569792.jpg" alt="Story 356173" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>CES  returns to Las Vegas<br/><span style="font-size:11px">Business 2:57 pm - 735 views</span></a></li>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:0 0 15px 0"><a href="/edition/news-story-356163-6-.htm#356163"><img src="/content/2022/1/square/thumb/2022010511010-61d5c11a783312144d68e77ejpeg_p3569842.jpg" alt="Story 356163" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Shopify loses crown<br/><span style="font-size:11px">Business 2:23 pm - 4,413 views</span></a></li>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:0 0 5px 0"><a href="/edition/news-story-356123-6-.htm#356123"><img src="/content/2022/1/square/thumb/2022010511010-61d5c0c4345ec55f89424451jpeg_p3569763.jpg" alt="Story 356123" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Vancouver sales hit record<br/><span style="font-size:11px">Business 9:38 am - 2,939 views</span></a></li>
</ul>
<ul class="sf2col">
			<li><a href="/edition/news-story--66-.htm">Sponsored Video</a></li>
			<li><a href="/themarket/">The Market</a></li>
			<li><a href="/pressroom/">Press Room</a></li>
			<li><a href="https://classifieds.castanet.net/cat/services/">Services</a></li>
			<li><a href="https://classifieds.castanet.net/cat/real_estate/business_opportunities/">Biz Opportunities</a></li>
			<li><a href="/edition/news-story--63-.htm">Think Local</a></li>
</ul>
<ul class="sf2col2">
			<li><a href="https://okanaganedge.net/" target="_blank" rel="noopener" style="text-decoration:underline">Okanagan Edge</a></li>
			<li><a href="https://okanaganedge.net/category/okanagan-biz/" target="_blank" rel="noopener">Okanagan Biz</a></li>
			<li><a href="https://okanaganedge.net/category/bc-biz/" target="_blank" rel="noopener">BC Biz</a></li>
			<li><a href="https://okanaganedge.net/category/community/got-the-edge/" target="_blank" rel="noopener">Got the Edge</a></li>
			<li><a href="https://okanaganedge.net/category/community/get-involved/" target="_blank" rel="noopener">Get Involved</a></li>
			<li><a href="https://okanaganedge.net/category/business-buzz/" target="_blank" rel="noopener">Business Buzz</a></li>
		</ul>
<div style="clear:both"></div>
		</div>
</div>
	</div>
	</li>
	<li id="sfSports">
	<a href="/edition/news-story--7-.htm">Sports</a>
	<div class="sf-mega">
<div class="sf-mega-frame">
		<div class="sf-mega-section">
		<ul>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:10px 0 15px 0"><a href="/edition/news-story-356164-35-.htm#356164"><img src="/content/2022/1/square/thumb/bchl_p3569678._p3569846.jpg" alt="Story 356164" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>BCHL shutdown grows<br/><span style="font-size:11px">BCHL 2:27 pm - 3,812 views</span></a></li>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:0 0 15px 0"><a href="/edition/news-story-356162-7-.htm#356162"><img src="/content/2022/1/square/thumb/20211229051228-61cc38f2f8613b92d2b4e7d3jpeg_p3569843.jpg" alt="Story 356162" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Djokovic denied entry<br/><span style="font-size:11px">Australia 2:23 pm - 5,320 views</span></a></li>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:0 0 5px 0"><a href="/edition/news-story-356069-35-.htm#356069"><img src="/content/2022/1/square/thumb/bchl_p3569678.jpg" alt="Story 356069" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Covid hits BCHL Smokies<br/><span style="font-size:11px">BCHL  - 6,937 views</span></a></li>
</ul>
<ul class="sf2col">
			<li><a href="/edition/news-story--51-.htm">WHL</a></li>
			<li><a href="/edition/news-story--35-.htm">BCHL</a></li>
			<li><a href="/edition/news-story--44-.htm">BCFC</a></li>
			<li><a href="/edition/news-story--62-.htm">UBCO Heat</a></li>
			<li><a href="/golf/">Golf</a></li>
			<li><a href="/sports/penticton-speedway/">Penticton Speedway</a></li>
</ul>
<ul class="sf2col2">
			<li><a href="/sports/ski/">Ski</a></li>
			<li><a href="/ski/big-white/">Big White</a></li>
			<li><a href="/ski/silver-star/">Silver Star</a></li>
			<li><a href="/ski/apex/">Apex</a></li>
			<li><a href="/ski/baldy/">Baldy</a></li>
			<li><a href="/ski/sun-peaks/">Sun Peaks</a></li>
		</ul>
<div style="clear:both"></div>
		</div>
</div>
	</div>
	</li>
	<li id="sfShowBiz">
		<a href="/edition/news-story--8-.htm">ShowBiz</a>
		<div class="sf-mega">
<div class="sf-mega-frame">
		<div class="sf-mega-section">
		<ul>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:10px 0 15px 0"><a href="/edition/news-story-356191-8-.htm#356191"><img src="/content/2022/1/square/thumb/bang_63848_p.jpg" alt="Story 356191" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Grammy Awards postponed<br/><span style="font-size:11px">Entertainment 4:26 pm - 1,520 views</span></a></li>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:0 0 15px 0"><a href="/edition/news-story-356190-8-.htm#356190"><img src="/content/2022/1/square/thumb/bang_63838_p.jpg" alt="Story 356190" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Joe Exotic fundraising<br/><span style="font-size:11px">Entertainment 4:26 pm - 306 views</span></a></li>
<li style="clear:both;height:50px;overflow:hidden;line-height:14px;padding:0 0 5px 0"><a href="/edition/news-story-356112-8-.htm#356112"><img src="/content/2022/1/square/thumb/bang_63812_p.jpg" alt="Story 356112" style="float:left;width:50px;height:50px;margin:0 5px 0 0;border-radius:6px"/>Cher refuses to go grey<br/><span style="font-size:11px">Entertainment 7:44 am - 4,568 views</span></a></li>
</ul>
<ul class="sf2col">
		<li><a href="https://tvlistings.zap2it.com/">TV Listings</a></li>
		<li><a href="/books.htm">Books</a></li>
		<li><a href="/edition/news-story--25-.htm">Offbeat</a></li>
		<li><a href="/edition/news-story--57-.htm">Around the Web</a></li>
		<li><a href="/edition/news-story--949-.htm">Heather's Horoscope</a></li>
</ul>
<ul class="sf2col2">
		<li><a href="https://thetango.net/" target="_blank" rel="noopener" style="text-decoration:underline">The Tango</a></li>
		<li><a href="https://thetango.net/category/daily-dose/" target="_blank" rel="noopener">Daily Dose</a></li>
		<li><a href="https://thetango.net/category/must-watch/" target="_blank" rel="noopener">Must Watch</a></li>
		<li><a href="https://thetango.net/category/galleries/" target="_blank" rel="noopener">Galleries</a></li>
		<li><a href="https://thetango.net/category/showbiz/" target="_blank" rel="noopener">Showbiz</a></li>
		<li><a href="https://thetango.net/category/music/" target="_blank" rel="noopener">Music</a></li>
		</ul>
<div style="clear:both"></div>
		</div>
</div>
		</div>
	</li>	
	<li id="sfClassifieds">
		<a href="https://classifieds.castanet.net/">Classifieds</a>
		<div class="sf-mega">
<div class="sf-mega-frame">
		<div class="sf-mega-section">
		<ul class="sf2col">
<li><a href="https://classifieds.castanet.net/my_ads.php" class="sfbutton">Login</a></li>
			<li><a href="https://classifieds.castanet.net/live/">Marketplace Live</a></li>
			<li><a href="https://classifieds.castanet.net/cat/jobs/">Jobs</a></li>
			<li><a href="https://classifieds.castanet.net/cat/real_estate/">Real Estate</a></li>
			<li><a href="https://classifieds.castanet.net/cat/rentals/">Rentals</a></li>
			<li><a href="https://classifieds.castanet.net/cat/vehicles/">Vehicles</a></li>
			<li><a href="https://classifieds.castanet.net/cat/auto_parts/">Auto Parts</a></li>
			<li><a href="https://classifieds.castanet.net/cat/rec_vehicles/">Rec Vehicles</a></li>
			<li><a href="https://classifieds.castanet.net/cat/house-home/">House-Home</a></li>
			<li><a href="https://classifieds.castanet.net/cat/furniture/">Furniture</a></li>
			<li><a href="https://classifieds.castanet.net/cat/electronics/">Electronics</a></li>
			<li><a href="https://classifieds.castanet.net/cat/fashion/">Fashion</a></li>
			<li><a href="https://classifieds.castanet.net/cat/kids/">Kids</a></li>
			<li><a href="https://classifieds.castanet.net/cat/sports-health/">Sports-Health</a></li>
		</ul>
<ul class="sf2col2">
<li><a href="/help/" class="sfbutton">Help</a></li>
<li><a href="https://www.castanetautomall.com/" target="_blank" rel="noopener">Automall</a></li>
<li><a href="https://www.rvpowersports.com/" target="_blank" rel="noopener">RV-Boats-Powersports</a></li>
<li><a href="https://classifieds.castanet.net/flyers/">Flyers</a></li>
			<li><a href="https://classifieds.castanet.net/cat/hobbies-music/">Hobbies-Music</a></li>
			<li><a href="https://classifieds.castanet.net/cat/library/">Library</a></li>
			<li><a href="https://classifieds.castanet.net/cat/vintage-antiques/">Vintage-Antiques</a></li>
			<li><a href="https://classifieds.castanet.net/cat/home_improvement/">Home Improvement</a></li>
			<li><a href="https://classifieds.castanet.net/cat/commercial-business/">Commercial-Business</a></li>
			<li><a href="https://classifieds.castanet.net/cat/farmers_market/">Farmer's Market</a></li>
			<li><a href="https://classifieds.castanet.net/cat/horse-farm-pets/">Horse-Farm-Pets</a></li>
			<li><a href="https://classifieds.castanet.net/cat/services/">Services</a></li>
			<li><a href="https://classifieds.castanet.net/cat/garage-free-auctions/">Garage-Free-Auctions</a></li>
			<li><a href="/stores/">Stores</a></li>
			<li><a href="https://classifieds.castanet.net/Classifieds%20Rate%20Sheet%20-%20Sept%201,%202019.pdf" target="_blank" rel="noopener">Classifieds Rate Sheet</a></li>
</ul>
<div style="clear:both"></div>
		</div>
</div>
		</div>
	</li>
	<li id="sfRealEstate">
		<a href="/realestate/">Real Estate</a>
		<div class="sf-mega">
<div class="sf-mega-frame">
		<div class="sf-mega-section">
		<ul>
			<li><a href="https://classifieds.castanet.net/cat/real_estate/">Listings</a></li>
			<li><a href="https://classifieds.castanet.net/cat/rentals/">Rentals</a></li>
			<li><a href="/showhomes/">Showhome Showcase</a></li>
			<li><a href="/edition/news-story--31-.htm">Luxury Homes</a></li>
			<li><a href="/edition/news-story--1044-.htm">Investment Real Estate</a></li>			
			<li><a href="https://classifieds.castanet.net/cat/real_estate/open_houses_no_showhomes_please/">Open Houses</a></li>
		</ul>
		</div>
</div>
		</div>	
	</li>

	<li id="sfCommunity">
		<a href="/opinion/">Opinion</a>
		<div class="sf-mega">
<div class="sf-mega-frame">
		<div class="sf-mega-section">
		<ul>
			<li><a href="/edition/news-story--11-.htm">Poll</a></li>
			<li><a href="/edition/news-story--10-.htm">Letters</a></li>
			<li><a href="https://forums.castanet.net/">Forums</a></li>
			<li><a href="/columnists/">Columnists</a></li>
			<li><a href="/edition/news-story--56-.htm">Opinion</a></li>
		</ul>
		</div>
</div>
		</div>
	</li>
	<li id="sfCity">
		<a href="/our-town/">Our Town</a>
		<div class="sf-mega">
<div class="sf-mega-frame">
		<div class="sf-mega-section">
		<ul class="sf2col">
			<li><a href="/obituaries/">Obituaries</a></li>
			<li><a href="/themarket/">The Market</a></li>
			<li><a href="/adopt-a-pet/">Adopt-a-Pet</a></li>
			<li><a href="/events/">Events</a></li>
			<li><a href="/movies/">Movies</a></li>
			<li><a href="/scenic-web-cams/">Cams</a></li>
<li><a href="/gas-prices/">Gas Prices</a></li>
			<li><a href="/gallery/">Gallery</a></li>
<li><a href="/celebrations/">Celebrations</a></li>
<li><a href="/contests/">Contests</a></li>
			<li><span style="position:absolute;top:-2px;font-size:24px;text-decoration:none !important;color:#000">&lsaquo;</span> &nbsp; &nbsp;<a href="/city/" style="position:relative" onmouseover="flyout(this);" id="citylink" class="taphover">Cities </a>
<div>
		<ul class="sf2col">
			<li><a href="https://www.cityofarmstrong.bc.ca" target="_blank" rel="noopener">Armstrong</a></li>
			<li><a href="https://www.cityofenderby.com" target="_blank" rel="noopener">Enderby</a></li>
			<li><a href="https://www.kamloops.ca" target="_blank" rel="noopener">Kamloops</a></li>
			<li><a href="https://www.kelowna.ca" target="_blank" rel="noopener">Kelowna</a></li>
			<li>&nbsp;&nbsp;<a href="https://www.kelowna.ca/roads-transportation/parking/parking-tickets-service-requests" target="_blank" rel="noopener">Pay Parking Tickets</a></li>
			<li><a href="https://www.keremeos.ca" target="_blank" rel="noopener">Keremeos</a></li>
			<li><a href="https://www.lakecountry.bc.ca" target="_blank" rel="noopener">Lake Country</a></li>
			<li><a href="https://www.merritt.ca" target="_blank" rel="noopener">Merritt</a></li>
			<li><a href="https://www.oliver.ca" target="_blank" rel="noopener">Oliver</a></li>
			<li><a href="https://www.osoyoos.ca" target="_blank" rel="noopener">Osoyoos</a></li>
			<li><a href="https://www.peachland.ca" target="_blank" rel="noopener">Peachland</a></li>
</ul>
<ul class="sf2col2">
			<li><a href="https://www.penticton.ca" target="_blank" rel="noopener">Penticton</a></li>
			<li><a href="https://www.summerland.ca" target="_blank" rel="noopener">Summerland</a></li>
			<li><a href="https://www.vernon.ca" target="_blank" rel="noopener">Vernon</a></li>
			<li><a href="https://www.westkelownacity.ca" target="_blank" rel="noopener">West Kelowna</a></li>
			<li><a href="https://www.wfn.ca" target="_blank" rel="noopener">Westbank First Nation</a></li>
			<li><a href="https://www.regionaldistrict.com" target="_blank" rel="noopener">RDCO</a></li>
			<li><a href="https://www.rdos.bc.ca" target="_blank" rel="noopener">RDOS</a></li>
			<li><a href="https://www.tnrd.ca" target="_blank" rel="noopener">TNRD</a></li>
			<li><a href="https://www.interiorhealth.ca" target="_blank" rel="noopener">Interior Health</a></li>
			<li><a href="https://www.orl.bc.ca" target="_blank" rel="noopener">Library</a></li>
			<li><a href="https://ok.ubc.ca" target="_blank" rel="noopener">UBC Okanagan</a></li>
			<li><a href="https://www.okanagan.bc.ca" target="_blank" rel="noopener">Okanagan College</a></li>
		</ul>
</div>
			<img src="/mh/flyout-fin.png" alt="city links" class="flyout-fin" /></li>
		</ul>
<ul class="sf2col2">
			<li><a href="/edition/news-story--42-.htm">Get Involved</a></li>
<li><a href="/food-and-drink/">Food &amp; Drink</a></li>
<li><a href="/edition/news-story--14-.htm">Wine Reviews</a></li>
			<li><a href="/wine/region/okanagan-valley/">Wine Maps</a></li>
<li><a href="/edition/news-story--24-.htm">Campus Life Okanagan</a></li>
			<li><a href="/edition/news-story--49-.htm">Campus Life Kamloops</a></li>
<li><a href="https://bctransit.com/" target="_blank" rel="noopener">Bus Schedule</a></li>
			<li><a href="https://ylw.kelowna.ca/passengers/arrivals" target="_blank" rel="noopener">YLW Arrive</a> / <a href="https://ylw.kelowna.ca/passengers/departures" target="_blank" rel="noopener">Depart</a></li>
			<li><a href="/kelownacouncil/">Kelowna Council</a></li>
			<li><a href="/edition/news-story--967-.htm">Crime Stoppers</a></li>
</ul>
<div style="clear:both"></div>
		</div>
</div>
		</div>
	</li>
	<li id="sfWeather">
		<a href="/weather/">Weather</a>
		<div class="sf-mega">
<div class="sf-mega-frame">
		<div class="sf-mega-section"> 
		<ul>
		<li><a href="/weather/Kelowna">Kelowna</a></li>
		<li><a href="/weather/Penticton">Penticton</a></li>
		<li><a href="/weather/Vernon">Vernon</a></li>
		<li><a href="/weather/Salmon-Arm">Salmon Arm</a></li>
		<li><a href="/weather/Kamloops">Kamloops</a></li>
		<li><a href="/weather/Vancouver">Vancouver</a></li>
		</ul>
		</div>
</div>
		</div>
	</li> 
</ul>
</div>
<div style="clear:both"></div>
	
<script type="text/javascript">
if (sfPage) { $('#'+sfPage).addClass("current"); }
$("#hdrbuttons a").click(function(){$.get("/ybclick.php?name="+$(this).attr('id'));});
$(".mhsform").submit(function(e){e.preventDefault();var _this=$(this);$.ajax("/ybclick.php?name="+_this.attr('name')).then(function(resp) {_this.unbind('submit').submit();})});
</script>
</div>
	<div id="content">
		<div id="hdad">
			<div id="hdpromo">
<div style="width:230px;height:90px;border-radius:7px;overflow:hidden"><a href="https://www.castanet.net/cgi-bin2/stats/clickcounter.cgi?id=186852&amp;cid=270539&amp;region=700" rel="nofollow" target="_blank"><img src="https://x.castanet.net/CastanetKelowna/22-01/display/Apparel-January-PR1.jpg" height="90" width="230" alt="186852"/></a></div>			</div>
			<div id="hdright">
<div style="width:728px;height:90px;border-radius:7px;overflow:hidden"><a href="https://www.castanet.net/cgi-bin2/stats/clickcounter.cgi?id=186018&amp;cid=268988&amp;region=26" rel="nofollow" target="_blank"><img src="https://x.castanet.net/prospects/0/OKPension-LB2.gif" height="90" width="728" alt="186018"/></a></div>			</div>
			<div class="crow"></div>
		</div>
		<div class="crow"></div>
		<div id="lnews">
<div id="newsheader">Kelowna&nbsp;&nbsp;</div>
<div class="newsstory" itemscope itemtype="https://schema.org/NewsArticle">
<h1 class="newsheadlinefull" itemprop="headline">Snow piling up in Kelowna as crews brace for another dump</h1><h2 class="newsheadline hasfull" itemprop="alternativeHeadline">Plow crews getting buried</h2><div class="byline"><a href="/reporter/Colin-Dacre" itemscope itemprop="author" itemtype="https://schema.org/Person"><span itemprop="name">Colin Dacre</span></a> - <span itemprop="datePublished" datetime="2022-01-05T16:07:00">Jan 5, 2022 / 4:07 pm</span><span class="storyid"> | Story: 356184</span></div>
<div itemprop="articleBody">
<div class="gallery" id="photo3569873">
<div class="gallery_img hdgallery"><img class="large_overlay" height="372" limg="/content/2022/1/large/1640730689-img_20211228_133129223_mp._p3569873.jpg" src="/content/2022/1/1640730689-img_20211228_133129223_mp._p3569873.jpg" width="640" />
<div class="photo_credit">Photo: Henry Stanski</div>

<div class="photo_cutline" style="width:635px">Snow is piling up in the Central Okanagan</div>
</div>
</div>

<p>Weary snow clearing crews in Central Okanagan communities are gearing up for another dump.</p>

<p>Between 15 and 20 centimetres are expected to fall on the region Wednesday night, following up to the five to 10 cm that fell Tuesday night.</p>

<p>Successive snowfall events have resulted in plow teams falling behind over the past few weeks, said City of Kelowna manager of public works Geert Bos.</p>

<p>&ldquo;The absence of those breaks in between the different snow events makes it really difficult to keep up, especially because we&#39;re staffed and equipped for what we call the average Kelowna winter,&rdquo; he said.</p>

<p>Kelowna roads are cleared on a priority basis with targets of eight hours, 12 hours and 48 hours after snowfall depending on the roadway. Sidewalks are supposed to be cleared in 24 hours.</p>

<p>&ldquo;What happens though, if you get another event within 48 hours of your last event, we&#39;re basically re-shifting our priorities back to the priority one roads&rdquo; he said.</p>

<p>The sustained cold weather has resulted in all of the snow that falls sticking to the ground, and piling up.</p>

<p>Bos says Kelowna is designed to handle about 40 cm of accumulation without the need for the removal of snow banks, a mark the city will blow past tonight.</p>

<p>&ldquo;We&#39;ll know most definitely be into the snow removal scenario starting next week,&rdquo; he said, explaining the municipality doesn&rsquo;t operate a singular large snow dump like northern communities but has several storage locations.</p>

<p>Kelowna announced its <a href="https://www.kelowna.ca/roads-transportation/roads-sidewalks/snow-removal-ice-control" target="_blank">parking ban</a> on designated snow routes will be going into place on Jan. 6 at 3 p.m. Residents are asked to keep their vehicles off the street to allow plows to work. Violating vehicles will be ticketed or towed.</p>

<p>&ldquo;With accumulations approaching 50 cm to date and more on the way, we really need the community&rsquo;s help in clearing the way,&rdquo; said Bos. &ldquo;Moving vehicles off the street is a crucial step in ensuring plows can clear streets quickly and effectively.&rdquo;</p>

<p>A downtown overnight parking ban has also been announced for the downtown core and Pandosy area, effective Jan. 8 at 10 p.m. The ban will be in place 10 p.m. to 7 a.m. until further notice.</p>

<p>The downtown area covered by the ban includes between Harvey Avenue and Clement Avenue, bordered by Water Street and Richter Street. In Pandosy, impacted areas include from Raymer Avenue to KLO Road between Tutt Street and Pandosy Street.</p>

<p>Vehicles still parked on the street after the ban begins will be towed to the closest non-obstructive location (i.e., down the street or around the corner).</p>

<p>Depending on the weather station, Bos said Kelowna has already received three to four times the normal amount of snow this winter. The municipality plowed through $860,000 worth of snow clearing budget in December alone. In the entire year, $2.1 million is budgeted.</p>

<p>That made for a very busy holiday season for crews.</p>

<p>&ldquo;Many of them didn&#39;t get to spend an awful lot of time with their families over Christmas. And I just wanted to give a thank you to the teams for doing a fantastic job,&rdquo; Bos said.</p>

<p><strong>WEST KELOWNA </strong></p>

<p>On the Westside, the City of West Kelowna says snow clearing contractors are working &ldquo;around the clock&rdquo; managing the &ldquo;challenging conditions.&rdquo;</p>

<p>&ldquo;Please be respectful to crews and staff; the city appreciates your patience and understanding as roads, sidewalks and bus stops are being maintained in priority order,&rdquo; the city said Wednesday.</p>

<p>With the extent of the snowfall expected, West Kelowna is warning residents it may be more than 48 hours before they can get to some priority 3 roads.</p>

<p>While no formal parking restrictions are in place, residents are encouraged to stay off the road.</p>

<p>If crews have not been to your West Kelowna street after more than 48 hours since the last snowfall, residents can contact the city at 778-797-2225 during office hours 7:30 a.m. to 3:30 p.m. Monday to Friday, excluding holidays. After hours, call AEL at 1-866-353-3136.</p>

<div class="gallery" id="photo3569874">
<div class="gallery_img hdgallery"><img class="large_overlay" height="360" limg="/content/2022/1/large/p9990444_p3569874.jpg" src="/content/2022/1/p9990444_p3569874.jpg" width="640" />
<div class="photo_credit">Photo: Colin Dacre</div>

<div class="photo_cutline" style="width:635px">Downtown Kelowna on Wednesday.</div>
</div>
</div>
</div>
</div>
<div class="contentfooter">
<p class="backhome"><a href="/">Back to Homepage</a></p>
<a class="sfoot1" href="/contactus/report_typo.php?story=356184" target="_blank" rel="nofollow"><span>Typos</span></a><a class="sfoot2" href="/contactus/news-tips.php"><span>News Tips</span></a><a class="sfoot3" href="https://forums.castanet.net/"><span>Forums</span></a>
<div class="addthis_toolbox addthis_default_style addthis_32x32_style storyshare" addthis:url="https://www.castanet.net/news/Kelowna/356184/Snow-piling-up-in-Kelowna-as-crews-brace-for-another-dump" addthis:title="Snow piling up in Kelowna as crews brace for another dump - Kelowna News" addthis:description="Weary snow clearing crews in Central Okanagan communities are gearing up for another dump." style="height:44px">
<a class="addthis_button_facebook"></a>
<a class="addthis_button_twitter"></a>
<a class="addthis_button_email"></a>
<a class="addthis_counter addthis_bubble_style"></a>
</div>
<div class="newsletter">
<div class="sfoot4">
<p>Must-Read Stories</p>
<span>Get all the day's most vital news with our newsletter, sent every weekday.</span>
</div>
<div class="mc_embed_signup">
<form action="https://glaciermedia.us5.list-manage.com/subscribe/post?u=cca0520b5e122304ac86be48e&amp;id=be97587725" method="post" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
<input type="email" value="" name="EMAIL" class="required email" placeholder="Enter Email Address" required />
<div style="position:absolute;left:-5000px" aria-hidden="true"><input type="text" name="b_cca0520b5e122304ac86be48e_be97587725" tabindex="-1" value="" /></div>
<input type="submit" value="Sign Me Up!" name="subscribe" class="button" />
</form>
</div>
</div>
</div>
<div class="crow"></div>
<div class="crow"></div><br/><br/>
<a href="/news/Kelowna/" id="newsarchive">More Kelowna News</a><br/><br/>
		</div>
<div id="rnews">
<div style="width:300px;height:250px;border-radius:7px;overflow:hidden"><a href="https://www.castanet.net/cgi-bin2/stats/clickcounter.cgi?id=186665&amp;cid=269974&amp;region=25" rel="nofollow" target="_blank"><img src="https://x.castanet.net/PredatorRidge/21-12/display/PredatorRidge-WinterMagic-MR1.gif" height="250" width="300" alt="186665"/></a></div><div class="recent-title">RECENT STORIES</div><div class="recent-news"><ul id="body1">
<li><a href='/edition/news-story-356196-5-.htm#356196'><div class="recent-img" style="background-image:url(/content/2022/1/thumb/356196_0.jpg);"></div><div class='recent-info'><span class='recent-headline'>Fires could have been worse</span><span class='recent-sub'>Colorado - 5:06 pm</span></div></a></li>
<li><a href='/edition/news-story-356183-2-.htm#356183'><div class="recent-img" style="background-image:url(/content/2022/1/thumb/356183_1.jpg);"></div><div class='recent-info'><span class='recent-headline'>New mask rules for SD83</span><span class='recent-sub'>Salmon Arm - 5:00 pm</span></div></a></li>
<li><a href='/edition/news-story-356193-48-.htm#356193'><div class="recent-img" style="background-image:url(/content/2022/1/thumb/356193_1.jpg);"></div><div class='recent-info'><span class='recent-headline'>Opposition to liquor store</span><span class='recent-sub'>Kamloops - 4:36 pm</span></div></a></li>
<li><a href='/edition/news-story-356179-101-.htm#356179'><div class="recent-img" style="background-image:url(/content/2022/1/thumb/356179_1.jpg);"></div><div class='recent-info'><span class='recent-headline'>Boil water advisory issued</span><span class='recent-sub'>West Kelowna - 4:29 pm</span></div></a></li>
<li><a href='/edition/news-story-356191-8-.htm#356191'><div class="recent-img" style="background-image:url(/content/2022/1/thumbs/bang_63848_p.jpg);"></div><div class='recent-info'><span class='recent-headline'>Grammy Awards postponed</span><span class='recent-sub'>Entertainment - 4:26 pm</span></div></a></li>
</ul><a class='recent-morelink' href='/'>More Top Stories &gt;</a></div>
<div class="crow"></div>
<div style="width:300px;height:100px;border-radius:7px;overflow:hidden"><a href="https://www.castanet.net/cgi-bin2/stats/clickcounter.cgi?id=179737&amp;cid=257013&amp;region=687" rel="nofollow" target="_blank"><img src="https://x.castanet.net/BigWhite/21-12/display/Christmas-Availability-300x100-1.gif" height="100" width="300" alt="179737"/></a></div><br/><br/>
<div style="width:300px;height:100px;border-radius:7px;overflow:hidden"><a href="https://www.castanet.net/cgi-bin2/stats/clickcounter.cgi?id=185189&amp;cid=267252&amp;region=311" rel="nofollow" target="_blank"><img src="https://x.castanet.net/CityOfKelowna/21-11/display/CityOfKelowna-Abbotsford-Swoop-SR1A.jpg" height="100" width="300" alt="185189"/></a></div><br/><br/>
<div class="quicklinks"><span class="qlheader">Real Estate</span><div class='feature_line'><div id='feature_left'><a class="feat_link" href="https://classifieds.castanet.net/details/west_kelowna_gem/4595025/"><img src="https://c.castanet.net/img/45/4595025-1-1.jpg" alt="4595025" width="80" height="60" class="feat_img"/></a></div>
<div class="feat_details">#37 - 1929 Highway 97<br>
1 bedrooms 1 baths <br>
$129,000<br><a class="feat_link" href="https://classifieds.castanet.net/details/west_kelowna_gem/4595025/">more details</a><br></div><div class="clear"></div></div>
</div>
<div style="width:300px;height:250px;border-radius:7px;overflow:hidden"><a href="https://www.castanet.net/cgi-bin2/stats/clickcounter.cgi?id=184874&amp;cid=266418&amp;region=127" rel="nofollow" target="_blank"><img src="https://x.castanet.net/BCTreeFruits/21-12/display/BCTreeFruitsCoOp-Hiring-MR1.jpg" height="250" width="300" alt="184874"/></a></div><br/><br/>
<div style="width:300px;height:600px;border-radius:7px;overflow:hidden"><a href="https://www.castanet.net/cgi-bin2/stats/clickcounter.cgi?id=184505&amp;cid=265628&amp;region=563" rel="nofollow" target="_blank"><img src="https://x.castanet.net/KelownaTransmissionAutoRepair/21-10/display/KelownaTransmission-Welcome-HP1d.jpg" height="600" width="300" alt="184505"/></a></div><br/><br/>
<div id="featuredpet">
<h2>Kelowna SPCA Featured Pet</h2>
<a href="/adopt-a-pet/details/35735" style="width:300px;display:inline-block;text-align:center"><img src="/content/spca/thumbs/359530.jpg" alt="Reese" width="128" height="128"/></a><br/>
<a href="/adopt-a-pet/details/35735" class="petname">Reese</a>
<a class="petshelter" href="/adopt-a-pet/search/Area/1/">Kelowna SPCA &gt;</a>
</div>
<br/><br/>	
<div style="width:300px;height:250px;border-radius:7px;overflow:hidden"><a href="https://www.castanet.net/cgi-bin2/stats/clickcounter.cgi?id=185188&amp;cid=267246&amp;region=707" rel="nofollow" target="_blank"><img src="https://x.castanet.net/CityOfKelowna/21-11/display/CityOfKelowna-Abbotsford-Swoop-MR1A.jpg" height="250" width="300" alt="185188"/></a></div><br/><br/>
<div style="width:300px;height:600px;border-radius:7px;overflow:hidden"><a href="https://www.castanet.net/cgi-bin2/stats/clickcounter.cgi?id=176461&amp;cid=251103&amp;region=836" rel="nofollow" target="_blank"><img src="https://x.castanet.net/MilleniumSpecialtyAlloys/21-10/display/MilleniumSpecialtyAlloys-HP1.gif" height="600" width="300" alt="176461"/></a></div><br/><br/>
<div id="tango_top" style="background-image:url('/images/tango-widget-bg.png');background-repeat:no-repeat;background-size:100% 100%;width:300px;text-transform:uppercase;color:rgb(255,255,255);height:75px;font-family: 'Myriad Pro','Trebuchet MS',Arial,Helvetica,sans-serif;">
<a href="https://thetango.net/" class="tango_logo" target="_blank" rel="noopener">Most Recent on <img style="width:112px;position:absolute;top:-1px;right:-112px;display:inline-block" src="/images/logo_white.png" alt="TheTango.net"/></a></div><div class="thetango_widget">
<div class="tango_view"><a href='https://thetango.net/' target='_blank' rel="noopener"><img width="732" height="600" src="https://thetango.net/wp-content/uploads/2022/01/celebrities_that_stopped_aging_25_years_ago_640_33.jpg" class=" wp-post-image" alt="" loading="" /></a></div>
<div class="widget_contents">
<a href="https://thetango.net/" target="_blank" rel="noopener"><h3>Celebs that have stopped aging</h3><div class="tango_cats">Galleries</div></a>
<a href="https://thetango.net/" target="_blank" rel="noopener"><div style="position:relative;padding-top:0px;padding-bottom:10px">These celebrities look amazing, then and now! Mario Lopez at 25 Mario Lopez now at 48 Paul Rudd at 28 Paul Rudd now at 52 Dennis...</div></a>
<div class="tango-smaller-img"><a href='https://thetango.net/2022/01/05/celebs-that-have-stopped-aging-2/' target='_blank' rel="noopener"><img width="200" height="200" src="https://thetango.net/wp-content/uploads/2022/01/celebrities_that_stopped_aging_25_years_ago_640_high_72-200x200.jpg" class=" wp-post-image" alt="" loading="lazy" srcset="https://thetango.net/wp-content/uploads/2022/01/celebrities_that_stopped_aging_25_years_ago_640_high_72-200x200.jpg 200w, https://thetango.net/wp-content/uploads/2022/01/celebrities_that_stopped_aging_25_years_ago_640_high_72-600x600.jpg 600w" sizes="(max-width: 200px) 100vw, 200px" />
<div class="tango_titles">Celebs that have stopped aging (2)</div><div class="tango_cats">Galleries</div> Halle Berry at 31 Halle Berry at 55 Kate Winslet 25 years ago at...
</a></div>
<div class="tango-smaller-img"><a href='https://thetango.net/2022/01/05/car-backs-into-garage-door/' target='_blank' rel="noopener"><img width="200" height="200" src="https://thetango.net/wp-content/uploads/2022/01/car-backs-into-garage-door-200x200.jpg" class=" wp-post-image" alt="" loading="lazy" />
<div class="tango_titles">Car backs into garage door</div><div class="tango_cats">Must Watch</div> &#8220;My niece backed out of the garage and did not realize the...
</a></div>
<div class="tango-smaller-img"><a href='https://thetango.net/2022/01/05/andy-cohen-wont-apologise-for-nye-drunk-broadcast/' target='_blank' rel="noopener"><img width="200" height="200" src="https://thetango.net/wp-content/uploads/2022/01/andy_cohen_wont_apologise_for_nye_drunk_broadcast-200x200.jpg" class=" wp-post-image" alt="" loading="lazy" srcset="https://thetango.net/wp-content/uploads/2022/01/andy_cohen_wont_apologise_for_nye_drunk_broadcast-200x200.jpg 200w, https://thetango.net/wp-content/uploads/2022/01/andy_cohen_wont_apologise_for_nye_drunk_broadcast.jpg 650w" sizes="(max-width: 200px) 100vw, 200px" />
<div class="tango_titles">Andy Cohen won&#8217;t apologise for NYE drunk broadcast</div><div class="tango_cats">Showbiz</div> Andy Cohen won&#39;t be &quot;shamed&quot; for being drunk on New...
</a></div>
<div class="tango-smaller-img"><a href='https://thetango.net/2022/01/05/omg-photos/' target='_blank' rel="noopener"><img width="200" height="200" src="https://thetango.net/wp-content/uploads/2022/01/1641115042_ck315ef5uu-200x200.jpg" class=" wp-post-image" alt="" loading="lazy" srcset="https://thetango.net/wp-content/uploads/2022/01/1641115042_ck315ef5uu-200x200.jpg 200w, https://thetango.net/wp-content/uploads/2022/01/1641115042_ck315ef5uu-600x600.jpg 600w" sizes="(max-width: 200px) 100vw, 200px" />
<div class="tango_titles">OMG photos</div><div class="tango_cats">Galleries</div> This gallery is very weird, brace yourselves.
</a></div>
<div style="clear:both"></div></div></div><br/><br/>
<div style="width:300px">
<script src='https://securepubads.g.doubleclick.net/tag/js/gpt.js'>
googletag.pubads().definePassback('/4326737/atex_GNG-BC_site_section_subsection_bigbox_S1_Castanet', [[300, 250], [300, 300]]).display();
</script>
</div>
<div class="quicklinks">
<span class="qlheader">Okanagan Quick Links</span>
<a class="ql-related-links" href="https://www.kelowna.ca/" target="_blank">City of Kelowna</a><br/>
<a class="ql-related-links" href="https://ylw.kelowna.ca/passengers/arrivals" target="_blank">Airport Arrivals</a><br/>
<a class="ql-related-links" href="https://ylw.kelowna.ca/passengers/departures" target="_blank">Airport Departures</a><br/>
<a class="ql-related-links" href="https://forums.castanet.net/viewforum.php?f=23">Kelowna Discussion Forum</a><br/>	
<a class="ql-related-links" href="http://www.kelownasculturaldistrict.com" target="_blank">Kelowna's Cultural District</a><br/>
<a class="ql-related-links" href="http://www.busonline.ca/regions/kel/" target="_blank">Kelowna Transit</a><br/>
<a class="ql-related-links" href="https://www.kelowna.ca/roads-transportation/road-report" target="_blank">Kelowna Road Closures</a><br/>
<a class="ql-related-links" href="http://www.th.gov.bc.ca/WilliamRBennettBridge/index.htm" target="_blank">William R. Bennett Bridge</a><br/>
<a class="ql-related-links" href="http://www.tourismkelowna.com" target="_blank">Tourism Kelowna</a><br/>
<a class="ql-related-links" href="http://www.regionaldistrict.com/" target="_blank">Central Okanagan Regional District</a><br/>
<a class="ql-related-links" href="http://www.peachland.ca/" target="_blank">District of Peachland</a><br/>
<a class="ql-related-links" href="http://www.lakecountry.bc.ca/" target="_blank">District of Lake Country</a><br/>
<a class="ql-related-links" href="http://www.interiorhealth.ca/" target="_blank">Interior Health</a><br/>
<a class="ql-related-links" href="http://web.ubc.ca/okanagan/welcome.html" target="_blank">UBC Okanagan</a><br/>
<a class="ql-related-links" href="http://www.okanagan.bc.ca/site15.aspx" target="_blank">Okanagan College</a><br/>
<a class="ql-related-links" href="http://www.sd23.bc.ca/" target="_blank">School District 23</a><br/>
<a class="ql-related-links" href="http://www.orl.bc.ca/" target="_blank">Okanagan Regional Library</a>
</div>
<div id="roadreport"><a href="/traffic-cams/camera/119" onclick="ga('send','event','Road Report click','webcam');"><span>Kelowna Road Report</span><img src="/scenic-web-cams/assets/cameras/wr-bennett-bridge.jpg?202201051720" alt="WR Bennett Bridge" width="300" height="205"/></a><a href="https://www.bringittoboyd.com/" onclick="ga('send','event','Road Report click','Boyd');"><img src="/images/Boyd-PageWidget-1.jpg" alt="Boyd Autobody and Glass" width="300" height="57"/></a></div>
<!-- /4326737/Local_Raffle_Castanet -->
<div id='div-gpt-ad-1623945318670-0' style='min-width:300px;min-height:250px;margin-top:40px'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1623945318670-0'); });
</script>
</div>
<div style="margin:40px 0 40px 0;text-align:center;color:#000"><a href="https://rtdnacanada.com/"><img src="/img/RTNDA.jpg" alt="Castanet Proud Member of RTNDA Canada" width="300" height="115" loading="lazy"/></a></div>
<div id="sticky"><script src='https://securepubads.g.doubleclick.net/tag/js/gpt.js'>
googletag.pubads().definePassback('/1066367/300x600-general', [300, 600]).display();
</script>
</div>
</div>
		<div class="crow"></div>
<div style="width:728px;height:90px;border-radius:7px;overflow:hidden"><a href="https://www.castanet.net/cgi-bin2/stats/clickcounter.cgi?id=185947&amp;cid=268836&amp;region=784" rel="nofollow" target="_blank"><img src="https://x.castanet.net/PlayStoresInc/21-08/display/AugustAd-LB1.gif" height="90" width="728" alt="185947"/></a></div><div id="ftbot">
<div id="bftleft">
&copy; 2022 Castanet.net
<ul>
<li><a href="/homepage/" onclick="this.style.behavior='url(#default#homepage)';this.setHomePage('https://www.castanet.net/');">Make Castanet Your Homepage</a></li>
<li><a href="/contactus/news-tips.php">News Tips</a></li>
<li><a href="/advertise/">Advertising</a></li>
<li><a href="/contactus/">Contact Us</a></li>
</ul>
</div>
<div id="bftright">
</div>
<div class="crow"></div>
</div>
	</div>
</div>
</div>


<div id="backtotop"><a href="#" class="totop"></a><a href="#" class="homebtn"></a></div>
<script>function getCookie(name) {
	var re = new RegExp(name + "=([^;]+)");
	var value = re.exec(document.cookie);
	return (value != null) ? unescape(value[1]) : '0';
}

var winheight=0;
function flyout(el){
	fo_menu=$(el).parent().children('ul');
	if(winheight==0 ||winheight!=$(window).height()){
		$(fo_menu).css('top', '-100px');
		winheight=$(window).height();
	}
	fo_height=$(fo_menu).outerHeight();
	fo_bottom=($(fo_menu).offset().top + fo_height-$(window).scrollTop());
	if($(window).height()<fo_bottom){
		newtop=(fo_bottom-$(window).height()+105)*-1;
		$(fo_menu).css('top', newtop + 'px');
	}
}

$('a.taphover').on("touchstart", function (e) {
    "use strict"; //satisfy the code inspectors
	var link = $(this); //preselect the link

    if (link.hasClass('hover')) {
	return true;
    } else {
	 link.addClass("hover");
	flyout(link);
	$('a.taphover').not(this).removeClass("hover");
	e.preventDefault();
	return false;
    }
});
</script>
<script type="text/javascript" src="/js/main1n.js"></script>
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=castanet" defer></script>
<script type="text/javascript">if (navigator.userAgent.match(/iPhone/i) || navigator.userAgent.match(/iPad/i) || navigator.userAgent.match(/iPod/i) || navigator.userAgent.match(/Android/i) || navigator.userAgent.match(/BlackBerry/i)) {
var isPad=true;
var sticky_class="stick_pad";
var sticky_offset=15;
}else{ 
var isPad=false;
var sticky_class="stick";
var sticky_offset=90;
}
$(window).bind("load", function() {
	if($("#lnews").height()<=$("#rnews").height()) return;
	var s = $("#sticky");
	var pos = s.position();
	var p_height=$(document).height();
	var ad_height=s.height();
	$(window).scroll(function() {
		p_height=$(document).height();
		var windowpos = $(window).scrollTop();
		if(windowpos+ad_height+200>p_height-100){
			max_top=p_height-200-ad_height-10;
			s.css({"position":"absolute", "top":max_top+"px"})
			s.removeClass(sticky_class);
		}else{
			if ((windowpos+sticky_offset)>=pos.top) {
				s.css({"position":"", "top":""})
				s.addClass(sticky_class);
			} else {
				s.removeClass(sticky_class);
			}
		}
	});
});
$.fn.isOnScreen = function(){
    var win = $(window);
    var viewport = {
	top : win.scrollTop(),
	left : win.scrollLeft()
    };
    viewport.right = viewport.left + win.width();
    viewport.bottom = viewport.top + win.height();
    
    var bounds = this.offset();
    bounds.right = bounds.left + this.outerWidth();
    bounds.bottom = bounds.top + this.outerHeight();
    
    return (!(viewport.right < bounds.left || viewport.left > bounds.right || viewport.bottom < bounds.top || viewport.top > bounds.bottom));
};
</script>
</body>
</html>
